Bug 1375560 - Popup menus are misplaced when connected to external monitor and monitors not exactly side-by-side
Summary: Popup menus are misplaced when connected to external monitor and monitors not...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter-wayland
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: WaylandRelated
TreeView+ depends on / blocked
 
Reported: 2016-09-13 12:07 UTC by Noam Cohen
Modified: 2016-11-24 08:31 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-24 08:31:22 UTC


Attachments (Terms of Use)
Screenshot when lid is open (popup menu created not as expected) (538.12 KB, image/png)
2016-09-13 12:07 UTC, Noam Cohen
no flags Details
Screenshot when lid is closed (popup menu created as expected) (234.18 KB, image/png)
2016-09-13 12:07 UTC, Noam Cohen
no flags Details
My displays arrangement (100.44 KB, image/png)
2016-09-13 12:51 UTC, Noam Cohen
no flags Details
Output of "lshw" command (22.38 KB, text/plain)
2016-10-14 09:49 UTC, Noam Cohen
no flags Details
Output of "xrandr" command (shows details for XWAYLAND0 and XWAYLAND1) (221 bytes, text/plain)
2016-10-14 09:51 UTC, Noam Cohen
no flags Details

Description Noam Cohen 2016-09-13 12:07:10 UTC
Created attachment 1200476 [details]
Screenshot when lid is open (popup menu created not as expected)

Description of problem:


Version-Release number of selected component (if applicable):
Fedora 24

How reproducible:


Steps to Reproduce:
1. Login to a "Gnome on Wayland" session
2. Connect laptop to external monitor so that both displays are active.
3. Start an application (for example - Gnome Terminal)
4. Right click inside the terminal to open up a popup menu
5. Menu is not created where expected (problem)
6. Close laptop lid so that only external monitor is active
7. Right click to open the popup menu again - This time the menu will be created where expected


See both screenshots attached - "lid is closed.png" shows the popup menu inside the terminal window, as expected. "lid is open.png" shows the popup menu on the right (external) display created below the terminal window.

Comment 1 Noam Cohen 2016-09-13 12:07 UTC
Created attachment 1200477 [details]
Screenshot when lid is closed (popup menu created as expected)

Comment 2 Noam Cohen 2016-09-13 12:50:34 UTC
Not sure if it's related - but the two displays are not arranged side by side. See "Displays Arranagement.png" screenshot.

Comment 3 Noam Cohen 2016-09-13 12:51 UTC
Created attachment 1200484 [details]
My displays arrangement

Comment 4 Christopher Beland 2016-10-05 17:00:39 UTC
I'm experiencing a similar problem with Firefox and side-by-side monitors (built-in to the left of external) at different resolutions (1680x1050 and 2560x1440, respectively).  When I have Firefox full-screen on my *external* monitor and click on Edit, or View (but not File, the leftmost Firefox menu item), the popup appears on the *built-in* monitor, in the upper-left quadrant.

Comment 5 Noam Cohen 2016-10-14 09:48:44 UTC
Problem persists in Fedora 25 Beta. I checked things further, and it seems that as long as the two displays are arranged (combined) exactly side by side - the popup menus appear where expected. When I click on the "Arrange Combine Displays" button and drags one of the displays a little bit lower than the other - the problem starts.
Unlike for Christopher Beland - in my case both displays have the same resolution (1920x1080). Not sure if it is required, but  I'm also attaching the output of my "lshw" and "xrandr" commands.

Comment 6 Noam Cohen 2016-10-14 09:49 UTC
Created attachment 1210449 [details]
Output of "lshw" command

Comment 7 Noam Cohen 2016-10-14 09:51 UTC
Created attachment 1210450 [details]
Output of "xrandr" command (shows details for XWAYLAND0 and XWAYLAND1)

Comment 8 Noam Cohen 2016-11-24 08:31:22 UTC
Seems to be resolved in Fedora 25


Note You need to log in before you can comment on or make changes to this bug.