Bug 1375569 - [RFE] Support for dhcp_release6 on RHEL platform for OSP10
[RFE] Support for dhcp_release6 on RHEL platform for OSP10
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dnsmasq (Show other bugs)
7.4
Unspecified Unspecified
high Severity high
: rc
: 7.3
Assigned To: Petr Menšík
Jan Ščotka
Ioanna Gkioka
: EasyFix, FutureFeature, Patch
Depends On: 1375527
Blocks: 1400961 1380362 1393869 1411884
  Show dependency treegraph
 
Reported: 2016-09-13 08:41 EDT by Sridhar Gaddam
Modified: 2017-08-01 18:56 EDT (History)
12 users (show)

See Also:
Fixed In Version: dnsmasq-2.76-1.el7
Doc Type: Enhancement
Doc Text:
*dhcp_release6* now releases IPv6 addresses With this update, the *dhcp_release6* utility can release Dynamic Host Configuration Protocol version 6 (DHCPv6) leases for IPv6 addresses on the local dnsmasq server. See the dhcp_release6(1) man page for more information about the "dhcp_release6" command.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 18:56:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2117 normal SHIPPED_LIVE dnsmasq bug fix and enhancement update 2017-08-01 15:38:28 EDT

  None (edit)
Description Sridhar Gaddam 2016-09-13 08:41:12 EDT
Description of problem:
dhcp_release which is part of dnsmasq works only for IPv4 addresses.
For IPv6 addresses, a new utility named, dhcp_release6, is added and is available in stock dnsmasq[1] version 2.76

OpenStack Neutron dhcp-agent invokes [1] dhcp_release6 utility for releasing IPv6 addresses and this feature will be part of OpenStack Newton release (i.e., OSP10). 
This bug is to have the necessary platform support for using dhcp_release6 on RHEL platform.

[1] http://www.thekelleys.org.uk/dnsmasq/CHANGELOG
[2] https://review.openstack.org/#/c/301747/

Additional info:
A missing dhcp_release6 utility will not have impact on IPv4 use-cases but will affect the IPv6 dhcpv6-stateful subnet use-cases.
Comment 1 Nir Yechiel 2016-09-13 08:47:42 EDT
To clarify, RHOSP 10 is planned to be shipped on top of RHEL 7.3.

@Pavel, can you please review this bug? This is pretty important to us on the OpenStack side as this could break our support for IPv6.


Thanks,
Nir
Comment 22 errata-xmlrpc 2017-08-01 18:56:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2117

Note You need to log in before you can comment on or make changes to this bug.