Bug 1375596 - Ipa-server WebUI - long user/group name show wrong error message
Summary: Ipa-server WebUI - long user/group name show wrong error message
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Nikhil Dehadrai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-13 13:58 UTC by Pavel Picka
Modified: 2017-08-01 09:39 UTC (History)
6 users (show)

Fixed In Version: ipa-4.5.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:39:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2304 normal SHIPPED_LIVE ipa bug fix and enhancement update 2017-08-01 12:41:35 UTC

Description Pavel Picka 2016-09-13 13:58:53 UTC
Description of problem:
When user has more then 256 chars error message shows : 

"may only include letters, numbers, _, -, . and $"

if user should have more chars error message is not clear


Version-Release number of selected component (if applicable):
4.4.0-10

How reproducible:
alway


Steps to Reproduce:
1. create user or group within WebUI with more than 256 characters

Actual results:
"may only include letters, numbers, _, -, . and $"

Expected results:
something like " User cannot have more than 256 characters"

Comment 1 Martin Bašti 🖰 2016-09-13 14:15:16 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5822

Comment 2 Martin Bašti 🖰 2016-09-13 14:40:52 UTC
Is this really regression? IMO this never works.

Comment 5 Petr Vobornik 2016-09-13 15:59:28 UTC
+1 to Martin, this is not a regression

Comment 8 Kaleem 2016-09-26 11:34:50 UTC
Regression keyword taken back.. so clearing needinfo .

Comment 10 Nikhil Dehadrai 2017-06-02 10:37:30 UTC
Created attachment 1284378 [details]
User with more than 255 char

User with more than 255 char

Comment 12 Nikhil Dehadrai 2017-06-02 10:42:21 UTC
Created attachment 1284393 [details]
Invalid Group Name more than 255 Char

Invalid Group Name more than 255 Char

Comment 18 Nikhil Dehadrai 2017-06-02 14:43:45 UTC
Ipa-server: ipa-server-4.5.0-13.el7.x86_64

Verified that when user creates "user" or "group" names within WebUI with more than 255 characters, correct error message is displayed :
"Invalid 'login': can be at most 255 characters"

Refer the screenshot at Comment#10 and Comment#12.

Thus marking the status of bug to "VERIFIED".

Comment 19 errata-xmlrpc 2017-08-01 09:39:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2304


Note You need to log in before you can comment on or make changes to this bug.