Bug 1375721 - [abrt] initial-setup: common.py:356:_mark_screen_visited:AttributeError: 'NoneType' object has no attribute 'mark_screen_visited'
Summary: [abrt] initial-setup: common.py:356:_mark_screen_visited:AttributeError: 'Non...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: initial-setup
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Kolman
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: AcceptedFreezeException abrt_hash:515...
Depends On:
Blocks: F25BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2016-09-13 20:30 UTC by Giulio 'juliuxpigface'
Modified: 2016-09-27 00:33 UTC (History)
3 users (show)

Fixed In Version: initial-setup-0.3.43-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 00:33:09 UTC


Attachments (Terms of Use)
File: backtrace (1.51 KB, text/plain)
2016-09-13 20:30 UTC, Giulio 'juliuxpigface'
no flags Details
File: environ (145 bytes, text/plain)
2016-09-13 20:30 UTC, Giulio 'juliuxpigface'
no flags Details
File: initialsetuptext_journal.txt (3.87 KB, text/plain)
2016-09-13 20:30 UTC, Giulio 'juliuxpigface'
no flags Details

Description Giulio 'juliuxpigface' 2016-09-13 20:30:31 UTC
Description of problem:
Steps to reproduce:
1. Install a qemu/kvm guest from the 20160912 compose of Fedora 25 KDE.
2. Boot the newly installed system.
3. On initial-setup, type "1" in order to enter the user creation spoke.

Actual results:
1. initial-setup crashes and user can not create new accounts.

Expected results:
1. initial-setup should not crash and users should be able to create new accounts.

Additional info:
On qemu/kvm, there are racy conditions which make initial-setup.text the default 'first boot' utility.

Version-Release number of selected component:
initial-setup-0.3.42-1.fc25

Additional info:
reporter:       libreport-2.7.2
cmdline:        /usr/bin/python3 /usr/libexec/initial-setup/initial-setup-text --no-stdout-log
executable:     /usr/libexec/initial-setup/initial-setup-text
kernel:         4.8.0-0.rc4.git0.1.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       unknown
type:           Python3
uid:            0

Truncated backtrace:
common.py:356:_mark_screen_visited:AttributeError: 'NoneType' object has no attribute 'mark_screen_visited'

Traceback (most recent call last):
  File "/usr/libexec/initial-setup/initial-setup-text", line 8, in <module>
    is_instance.run()
  File "/usr/lib/python3.5/site-packages/initial_setup/__init__.py", line 308, in run
    ret = ui.run()
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/tui/__init__.py", line 188, in run
    return self._app.run()
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 314, in run
    self._mainloop()
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 345, in _mainloop
    if not self._do_redraw():
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 274, in _do_redraw
    self.current_screen = screen
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 523, in current_screen
    new_screen.entry()
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/common.py", line 344, in entry
    callback(self)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/common.py", line 356, in _mark_screen_visited
    screen_access.sam.mark_screen_visited(spoke_instance.__class__.__name__)
AttributeError: 'NoneType' object has no attribute 'mark_screen_visited'

Local variables in innermost frame:
spoke_instance: <pyanaconda.ui.tui.spokes.user.UserSpoke object at 0x7f3182ae05c0>
self: <pyanaconda.ui.tui.spokes.user.UserSpoke object at 0x7f3182ae05c0>

Comment 1 Giulio 'juliuxpigface' 2016-09-13 20:30:36 UTC
Created attachment 1200610 [details]
File: backtrace

Comment 2 Giulio 'juliuxpigface' 2016-09-13 20:30:37 UTC
Created attachment 1200611 [details]
File: environ

Comment 3 Giulio 'juliuxpigface' 2016-09-13 20:30:39 UTC
Created attachment 1200612 [details]
File: initialsetuptext_journal.txt

Comment 4 Giulio 'juliuxpigface' 2016-09-13 20:39:28 UTC
Since the graphical initial-service isn't shown on qemu-kvm for KDE (see also https://bugzilla.redhat.com/show_bug.cgi?id=1367910), I'm proposing this as Freeze Exception.

This is a partial violation of the "2.4.1 Expected installed system boot behavior" Fedora 25 Alpha release criterion (https://fedoraproject.org/wiki/Fedora_25_Alpha_Release_Criteria#Expected_installed_system_boot_behavior).

"A working mechanism to create a user account must be clearly presented during installation and/or first boot of the installed system."

Comment 5 Petr Schindler 2016-09-19 16:38:29 UTC
Discussed at 2016-09-19 blocker review meeting: [1]. 

This bug was accepted as Freeze Exception: inability to create a user in i-s is clearly a serious problem that cannot be fixed in an update. if this bug turns out to affect ARM it will likely be upgraded to a blocker, but for now we grant it an FE at least.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-09-19/

Comment 6 Martin Kolman 2016-09-20 15:51:28 UTC
A fix has been posted for review:
https://github.com/rhinstaller/initial-setup/pull/22

Comment 7 Fedora Update System 2016-09-23 05:24:36 UTC
initial-setup-0.3.43-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-66457e9af1

Comment 8 Fedora Update System 2016-09-27 00:33:09 UTC
initial-setup-0.3.43-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.