Bug 137582 - kfind hangs on search in FC3t3 and FC3rc3
kfind hangs on search in FC3t3 and FC3rc3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-29 12:36 EDT by Kim Lux
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-23 10:15:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kim Lux 2004-10-29 12:36:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
$kfind -v
Qt: 3.3.3
KDE: 3.3.0-5 Red Hat
KFind: 2.0

$rpm -q kfind: not found
Must be part of kdebase ?

When I run kfind for simple searches it hangs.  

Example: Named: MyProject  Look In: file:/home/krlux
Example: Named: *wlan0  Look In: file:/etc/

Version-Release number of selected component (if applicable):
2.0 ?  

How reproducible:
Always

Steps to Reproduce:
1. Open via start, put in the parameters and press find. 
2.
3.
    

Actual Results:  It hangs.  It doesn't return any results.  It won't
close.  It doesn't refresh its display.

Additional info:

It was a problem in FC3T3 and is still in FC3RC3.
Comment 1 Vesko Tomov 2004-11-20 12:58:54 EST
I have the exact same problem.  It was a problem for me in Fedora 2 
where I got around it by disabling FAM.  I found out that in Fedora 3 
FAM has been replaced by GAMIN, so I don't know if that has anything 
to do with it.  I don't know how to disable GAMIN.  So right now I 
can't search for files in KDE! 
Comment 2 Mike 2004-11-20 16:16:20 EST
It seems to be associated with gamin.  If I simpley move gam_server
out of the /usr/libexec directory, kill the gam_server process then
the kfind utility seems to work properly.  The test search I was using
was:

to search for "man" in the "/usr" directory and its subdirectories. 

Displays the symtpoms above with gam_server running and works fine
without it running.

Regards, Mike Klinke
Comment 3 Ngo Than 2004-11-23 10:15:06 EST
i have now added a patch in kdebase-3.3.1-10, which will fix this
problem. It will show up in rawhide soon. Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.