Bug 1375905 - "Normal" group type in the UI is confusing
Summary: "Normal" group type in the UI is confusing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Nikhil Dehadrai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-14 08:36 UTC by Aneta Šteflová Petrová
Modified: 2017-08-01 09:39 UTC (History)
5 users (show)

Fixed In Version: ipa-4.5.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:39:54 UTC
Target Upstream Version:


Attachments (Terms of Use)
Group Types with IPA-RHEL 74 (17.35 KB, image/png)
2017-06-02 10:53 UTC, Nikhil Dehadrai
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2304 normal SHIPPED_LIVE ipa bug fix and enhancement update 2017-08-01 12:41:35 UTC

Description Aneta Šteflová Petrová 2016-09-14 08:36:18 UTC
Description of problem:
The web UI has these three labels for group types: Normal, External, POSIX.

"Normal" is confusing because:
* It doesn't properly describe the group type (non-POSIX).
* What is actually considered normal? I would expect "normal" to mean "default", but the group type selected by default is actually "POSIX".


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
For example, when adding a new user group:
1. User Groups - click Add.
2. The "Add User Groups" dialog shows the available group types.

Actual results:
"Normal"

Expected results:
"Non-POSIX" would work better - it's clearer and more descriptive. It would also be consistent with CLI.

Additional info:

Comment 2 Petr Vobornik 2016-09-14 10:17:36 UTC
Makes sense.

Comment 3 Pavel Vomacka 2016-09-14 11:16:44 UTC
Agree. We can easily change it to 'Non-POSIX'. This was introduced in commit 44e86aa3bb7206991bbe1118ee3a35b6949b6ac9 .

Comment 4 Pavel Vomacka 2016-09-15 10:26:40 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6334

Comment 5 Martin Bašti 🖰 2016-09-21 11:23:42 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/0e6d6e403255649538224c409a0a279aaf9d5181

Comment 7 Nikhil Dehadrai 2017-06-02 10:52:45 UTC
Ipa-server: ipa-server-4.5.0-13.el7.x86_64


Verified that with latest version of IPA-server, on accessing path "Identity > Groups > Add" , we are now presented with following 3 group types:

Non-POSIX, External, POSIX. (See screenshot)

Thus marking the status of bug to "VERIFIED".

Comment 8 Nikhil Dehadrai 2017-06-02 10:53:31 UTC
Created attachment 1284396 [details]
Group Types with IPA-RHEL 74

Group Types with IPA-RHEL 74

Comment 9 errata-xmlrpc 2017-08-01 09:39:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2304


Note You need to log in before you can comment on or make changes to this bug.