Bug 1376040 - IPA client ipv6 - invalid --ip-address shows traceback
Summary: IPA client ipv6 - invalid --ip-address shows traceback
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Pavel Picka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-14 13:41 UTC by Pavel Picka
Modified: 2017-08-01 09:39 UTC (History)
5 users (show)

Fixed In Version: ipa-4.5.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:39:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2304 normal SHIPPED_LIVE ipa bug fix and enhancement update 2017-08-01 12:41:35 UTC

Description Pavel Picka 2016-09-14 13:41:08 UTC
Description of problem:
When specify invalid ipv6 in --ip-address, ipa-client-install shows traceback

Version-Release number of selected component (if applicable):
4.4.0-11

How reproducible:
always


Steps to Reproduce:
1. ipa-client-install --ip-address 2002:2222:: # non exist/present IPv6 

Actual results:
[root@rhel06 ~]# ipa-client-install --ip-address 2002:2244:6644:/128
WARNING: ntpd time&date synchronization service will not be configured as
conflicting service (chronyd) is enabled
Use --force-ntpd option to disable it and force configuration of ntpd

Traceback (most recent call last):
  File "/usr/sbin/ipa-client-install", line 3128, in <module>
    sys.exit(main())
  File "/usr/sbin/ipa-client-install", line 3109, in main
    rval = install(options, env, fstore, statestore)
  File "/usr/sbin/ipa-client-install", line 2306, in install
    if not check_ip_addresses(options):
  File "/usr/sbin/ipa-client-install", line 1793, in check_ip_addresses
    ipautil.CheckedIPAddress(ip, match_local=True)
  File "/usr/lib/python2.7/site-packages/ipapython/ipautil.py", line 138, in __init__
    super(CheckedIPAddress, self).__init__(addr)
  File "/usr/lib/python2.7/site-packages/ipapython/ipautil.py", line 123, in __init__
    self._net = netaddr.IPNetwork(addr, flags=self.netaddr_ip_flags)
  File "/usr/lib/python2.7/site-packages/netaddr/ip/__init__.py", line 926, in __init__
    raise AddrFormatError('invalid IPNetwork %s' % addr)
netaddr.core.AddrFormatError: invalid IPNetwork 2002:2244:6644:/128


Expected results:
error message of invalid IP specified

Comment 2 Tomas Krizek 2016-09-19 07:09:36 UTC
This is already fixed upstream.

Upstream ticket: https://fedorahosted.org/freeipa/ticket/6296

Comment 3 Martin Bašti 2016-09-19 07:57:31 UTC
This is *not* fixed. Ticket mentioned above solves only link-local addresses. This BZ is about showing traceback when incorrect address is used (e.g: 2001::db8::1). We should handle this nicely and show just error message not traceback.

Comment 4 Martin Babinsky 2016-09-21 08:27:40 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/ddf48f2fef344784b9e1918d2f2ee6feef9d4c04

Comment 6 Pavel Picka 2017-06-02 14:19:47 UTC
verified ipa-server-4.5.0-14.el7.x86_64

# ipa-client-install --ip-address 2002:2244:
Usage: ipa-client-install [options]

ipa-client-install: error: option --ip-address: invalid IP address 2002:2244:: failed to detect a valid IP address from '2002:2244:'

Comment 7 errata-xmlrpc 2017-08-01 09:39:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2304


Note You need to log in before you can comment on or make changes to this bug.