Bug 137617 - kwireless reports no network when session is resumed or network restarted
kwireless reports no network when session is resumed or network restarted
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2004-10-29 15:26 EDT by Kim Lux
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: FC6-update
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-30 10:45:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kim Lux 2004-10-29 15:26:05 EDT
Description of problem:

Kwireless reports no connection when there actually is one.  This
happens when a session is started where kwireless was in use in the
previous session or when kwrireless is in the system tray. 

I'm using ndiswrapper version 0.11.  It has worked well for me with no

Version-Release number of selected component (if applicable):


How reproducible: Every time. 

Steps to Reproduce:
1. Install kwireless in the tray.  Log out.  Log in.  Will show no
3. /etc/init.d/network restart. 
Actual results:

kwireless goes black with a red x through it even though wlan0 is work
ing fine.  By working fine I mean that the restart script reported
success and you can surf the internet. 

Expected results:

kwrireless should report a good connection and it strength, etc.

Additional info:

It worked fine in FC3T3.  I was happy to see it as a standard
component.  It kicks the Windows equivalent !  I can't wait to use it
with the sound feedback for finding good signals.
Comment 1 Kim Lux 2004-10-29 17:38:07 EDT
I should add some more information to this report:

a) I am running KDE, not gnome.

b) If I right click quit the kwireless appl. in the tray and start a
new one, it shows the network working like it should.  kwireless
works, it just doesn't find the network at the start of a session. 

c) kwireless is trying to find the connection, ie it flickers about
once every 2 seconds and refreshes the no network found text. 
Comment 2 Kim Lux 2004-11-01 15:22:57 EST
This appears to work properly with kernel 2.6.9-1.649. 
Comment 3 Kim Lux 2004-11-02 11:11:24 EST
This is still an isse with 2.6.9-1.649 
Comment 4 Kim Lux 2004-11-02 20:45:14 EST
The issue described occurs with smp kernels.  I am testing FC3rc3 
with a HP ZD7000 laptop which has a dual core P4 processor.  When I 
boot a smp kernel, info center shows 2 processors running.  Kwireless 
works fine with a non smp kernel.  
Comment 5 Matthew Miller 2006-07-10 16:19:58 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 6 Kim Lux 2006-10-30 10:15:14 EST
This issue seems to be resolved.  It can be closed as far as I am concerned.

Note You need to log in before you can comment on or make changes to this bug.