This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 137618 - overzealous oom handler
overzealous oom handler
Status: CLOSED DUPLICATE of bug 131251
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
http://freedesktop.org/~kidcrash/fedo...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-29 15:32 EDT by Carlos Romero
Modified: 2015-01-04 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-29 16:10:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Carlos Romero 2004-10-29 15:32:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041023 Epiphany/1.4.4

Description of problem:
oom-handler kills dozens of processes at a time.
im used to having kernel oom reap a single pid and be happy with it,
but since 2.6.9-rc series i've been having the reaper tear through
some benign processes including daemons.


Version-Release number of selected component (if applicable):
kernel-2.6.9-1.643

How reproducible:
Sometimes

Steps to Reproduce:
1.gnome desktop running on 128M/256swap
2.rpmbuild eg kernel,glibc in gnome-terminal
3.browse using epiphany until the kernel oom-handler is called


Expected Results:  kill a single memory hog like epiphany and be done
Comment 1 Dave Jones 2004-10-29 16:10:36 EDT

*** This bug has been marked as a duplicate of 131251 ***

Note You need to log in before you can comment on or make changes to this bug.