Bug 1376195 - qpid-displatch FTBFS on epel7
Summary: qpid-displatch FTBFS on epel7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: qpid-dispatch
Version: epel7
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Irina Boverman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: epel7aarch64
TreeView+ depends on / blocked
 
Reported: 2016-09-14 20:13 UTC by D. Marlin
Modified: 2016-10-19 02:56 UTC (History)
3 users (show)

Fixed In Version: qpid-dispatch-0.6.1-4.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-19 02:56:56 UTC
Type: Bug


Attachments (Terms of Use)

Description D. Marlin 2016-09-14 20:13:05 UTC
Description of problem:

qpid-displatch fails to build from source for Fedora EPEL7 using mock.


Version-Release number of selected component (if applicable):

qpid-dispatch-0.6.1-2.el7


How reproducible:

consistently.


Steps to Reproduce:
1. get qpid-dispatch-0.6.1-2.el7.src.rpm
2. mock build for EPEL7:
  mock -r epel-7-x86_64 qpid-dispatch-0.6.1-2.el7.src.rpm
3.


Actual results:

        :
+ %cmake3 -DDOC_INSTALL_DIR=/usr/share/doc/qpid-dispatch-0.6.1 -DCMAKE_BUILD_TYPE=RelWithDebInfo -DUSE_SETUP_PY=0 -DQD_DOC_INSTALL_DIR=/usr/share/doc/qpid-dispatch-0.6.1 -DBUILD_DOCS=ON -DCMAKE_SKIP_RPATH:BOOL=OFF .
/var/tmp/rpm-tmp.RYHWYU: line 29: fg: no job control

RPM build errors:
error: Bad exit status from /var/tmp/rpm-tmp.RYHWYU (%build)
    Bad exit status from /var/tmp/rpm-tmp.RYHWYU (%build)


Expected results:

builds without errors.


Additional info:

This appears to be due to a missing "%cmake3" macro.  The mock build pulls in the latest released version of cmake (2.8.11-5.el7), which does not provide this macro, for the buildroot.  If the spec file is modified to require cmake3:

-BuildRequires: cmake
+BuildRequires: cmake3

the build completes as it should.

Comment 1 Yaakov Selkowitz 2016-09-14 20:53:39 UTC
I think the reason this broke suddenly is that EPEL cmake3 had a Provides: cmake, meaning that anything in EPEL which BuildRequires: cmake would get cmake3.  That was wrong and just fixed.

Please note that EPEL7 will soon be specially rebuilt in order to enable aarch64.  Please bump release with the fixed BuildRequires so that this will succeed.

Comment 2 D. Marlin 2016-10-17 16:20:55 UTC
I believe this is complete:

  http://koji.fedoraproject.org/koji/buildinfo?buildID=804005

Can this BZ now be closed?


Note You need to log in before you can comment on or make changes to this bug.