Bug 137625 - K3b jumps ahead while burning DVD+RW with 2 files. FC3T3 and FC3rc3
K3b jumps ahead while burning DVD+RW with 2 files. FC3T3 and FC3rc3
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: k3b (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-29 15:52 EDT by Kim Lux
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-04 12:02:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kim Lux 2004-10-29 15:52:38 EDT
Description of problem:

K3b jumped to 80% written immediately upon writing and thus produced a
coaster DVD. 

Version-Release number of selected component (if applicable):

It did it twice in FC3T3 and once in FC3rc3. 

k3b-0.11.14-2


How reproducible:

Does it every time. 


Steps to Reproduce:

1. make 1 large (4.1GB) and one small (7.8 MB) tar files.  They were
made with tar -cvzf home.tgz /home and tar -cvzf etc.tgz /etc

2. Open K3B, select DVD data project and drag the two files onto the
data file window area, so they are in the project. 

3. Press the burn icon.  Change the name of the volume.  I tried both
"start multi session" and "Single Session" burning with the same results. 

4. Press Start.
  

Actual results:

K3B gets ready to burn normally.  Suddenly the progress bar jumps to
80% done and the writing speed is displayed at 3910x or something
absurb number. 

The writing then continues at a normal pace.  K3B reports success. 
The DVD is a coaster. 


Expected results:

It should write a good DVD. 


Additional info:

I'm using a 4x DVD burner in an HP notebook, which has worked well up
until now.  I burnt several DVDs earlier in the day with an assortment
of files on them with no problem.  I burnt a few CDRWs as well. 

I really like K3B.  Kudos for someone to come up with such a nicer
burner application.  I really like the way it can save a project. 
Downside: I wish I could get the project files run via a script for
croning purposes.
Comment 1 Harald Hoyer 2004-11-01 04:15:14 EST
iso9660, which is the file system on a CD/DVD does not allow files
bigger then 4GB! Try to use udf as the filesystem.
Comment 2 Harald Hoyer 2004-11-01 04:16:30 EST
as for scripting, man growisofs(1) . Very simple, easy to use command
line burning.
Comment 3 Kim Lux 2004-11-01 09:40:02 EST
I didn't know that iso9660 had the file size limitation.  That
explains why K3B worked fine on groups of smaller files but had
problems with this project.  I'll split the big file into 2 parts and
try writing it.

Now that I know this limitation, I think the write failure I saw could
have been handled better by K3B.  I think it should check how big the
files are before it tries to write them and alert the user of a file
>4GB when using iso9660, rather than failing the write like it did and
giveing the user no indication as to why.  

As for the scripting coment, I'd like to be able to call K3B with a
project that I've set up in K3B rather than using another command line
tool.

Ie: set up a project in K3B.  Test run it.  Then be able to place a
command with cron such that K3B starts and executes the K3B project
without any human intervention, like "k3b -e myproj.k3b".  The -e
option means to execute the project without human intervention.

I agree that other command line tools could be made to work, but I'd
like to center all our data backup routines on k3b because our people
will find it easier to use than a command line routine.  

Thanks. 

Note You need to log in before you can comment on or make changes to this bug.