Bug 137649 - kdebase: depends on xorg-x11-xdm and lm_sensors
kdebase: depends on xorg-x11-xdm and lm_sensors
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-29 18:30 EDT by Zack Cerza
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-31 15:22:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zack Cerza 2004-10-29 18:30:14 EDT
Description of problem:
When installing kdebase via yum, the following packages get pulled in:

lm_sensors
kdebase
xorg-x11-xdm

Obviously kdelibs is correct, but requiring xdm and lm_sensors doesn't
make much sense to me - I haven't seen another distro do that. Can
they be suggested, rather than depended on?

Version-Release number of selected component (if applicable):
kdebase-3.3.0-8.i386
Comment 1 Zack Cerza 2004-10-29 19:10:50 EDT
er, sadly, rpm doesn't have suggests... this report might be futile.
Comment 2 Bill Nottingham 2004-10-29 22:34:27 EDT
xorg-x11-xdm is because kdm requires some files from there, IIRC.

It requires libsensors.so.3, ergo, lm_sensors. (The package require:
is probably superfluous with the library require:, though)
Comment 3 Ngo Than 2004-10-31 15:22:12 EST
xorg-x11-xdm just include the config files which KDM/XDM share them.
And it's our intention. You haven't seen another distro do that,
because they add the config files in kdebase.

yes, the "require: lm_sensors" is superfluous and should be removed.

Note You need to log in before you can comment on or make changes to this bug.