Bug 137650 - Install reports "Probably out of disk space" when copying install image.
Install reports "Probably out of disk space" when copying install image.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-29 18:30 EDT by Kim Lux
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 10:18:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kim Lux 2004-10-29 18:30:35 EDT
Description of problem:

The FC3rc3 install process gave me an out of disk space error when
installing on a formerly used hard drive with empty partitions. 

I was installing FC3rc3 from CDROM (CDRW disks) on a dual boot machine
with a previous install of FC3T3.  I select a brand new installation,
not an upgrade of what is already there.  I'm manually partitioned the
drive with disk druid. 

I've tried partitioning 3 different ways: 1)leaving the partitions
alone, 2) removing them entirely and re adding and reformatting them
and 3) just reformatting them as they are.

There are 4 actual partitions on the disk: hda1 = XP, hda2 = /boot,
hda3 = swap; hda4 = placeholder, hda5 = "/"  All the Linux partitions
are empty, save for "lost and found".  I've checked their sizes in
linux-rescue by temporarily mounting them and then doing a df.

The error I received was:

"An error occurred transferring the install image to your hard drive.
 You are probably out of disk space."  It then take me back to the
start of the actual installation process.  I rebooted the install disk
several times.  I changed the partitions around.  I changed the
package selection.  

I watched and the system does seem to reformat the drive when it is 
supposed to.  (The drive light runs anyway.)  The progress bar of the
image copy gets to about 80% when the cdrom drive stops.  Then the
error message appears.  

The hard drive checks out fine (fsck from linux-rescue) and the cdrom
has passed "media test" three times.  I've also run a memcheck86 and
it too passes.

My laptop is about a month old and has been rock solid.  

Version-Release number of selected component (if applicable):

Whatever shipped on the Oct 28 version of the ISO rpms at
i386/fc3-rc/3/ at duke.edu. 


How reproducible:

I tried about 10 times to install with no success. 

Steps to Reproduce:

It did eventually install.  Truthfully I don't know what happened
because I was talking on the phone with a friend and pressing keys at
the same time and suddenly it was installing packages. 

I don't know if it is reproducable now because I haven't tried to
install on the laptop since.

Additional info:

The machine is an HP7280 laptop.  It has a 5400 RPM 80 GB drive and an
4x DVD burner/CDRW.  I burnt the ISO CDRW disks on this machine and
they passed validation testing in K3B as well as the media check on
the Linux boot disk.


The partition settings were:

/dev/hda1: XP 20 GB
/dev/hda2: /boot 100 MB ext3
/dev/hda3: swap  1 GB
/dev/hda4: logical
/dev/hda5: / remainder, ext3


I think that the package selected was small when it finally installed.
 My initial package selection was large and custom, ie workstation +
development tools, not server with X or a desktop install.

Which partition does anaconda copy the install image too ?  Is it
possible that it was using /boot and that the install image was bigger
than the space on it ?  Just an idea ?
Comment 1 Kim Lux 2004-10-31 03:32:30 EST
I was thinking that reporting more information to the user in this 
situation would be extremely helpful for debugging or for allowing 
the user to get his installation going.  Could the following be added 
to the displayed error message: 
 
a) size of the install image being copied. 
b) intended target partition/directory 
c) permissions on the target directory 
d) free space on the target directory 
e) error code returned from the copy process 
f) whether the failure involved a bad checksum at the end of the 
copy, ie dirty CDROM ? 
 
As it stands right now the user is thinking his partition isn't big 
enough/empty when in reality a number of issues could have caused the 
problem.  Because this is occurring during installation, there isn't 
an easy way to debug the problem, ie there is no running system.   
Comment 2 Jeremy Katz 2004-11-01 09:46:43 EST
Can you try booting with 'linux ide=nodma'?  Also, the full exception
gets logged to /tmp/anaconda.log and tty3.
Comment 3 Kim Lux 2004-11-01 10:05:54 EST
At the time it happened I didn't think of changing the boot command. 
BTW: Is there a list of all the available kernel boot parameters
somewhere ?  There must be about 20 different options, but I don't
know exactly what they are. 

I just checked /tmp and the exception log isn't there anymore.  I
wasn't watching tty3 when it happened.  I'll know for "next time", if
there is a next time, ie if it ever happens again. 

This was the third Linux install on that machine in a month.  We
installed FC2 on it with no problems, and then FC3T3.  I was surprized
to see fc3rc3 give problems. 

Should something like "you might want to try rebooting the
installation process with linux ide=nodma" be added to the error that
I received, or even "Check tty3 for more details" or "check
/tmp/anaconda.log for more details" be added to the error screen I saw
?  It certainly would have helped me. 
Comment 4 Jeremy Katz 2004-11-01 10:18:37 EST
The problem is that ide=nodma should only be needed if the kernel is
broken.  Which, unfortunately, it is far too often in this area :-/

A lot of the options are in the appendices of the old Red Hat Linux
install guides, but unfortunately, there isn't a concerted effort to
document kernel options upstream.  It woul dbe a nice project.
Comment 5 Kim Lux 2004-11-01 10:26:21 EST
I don't like to see this closed without ANY action on it.  I'd like to
see some hints added to the error dialog, such as to check tty3 or
/tmp/anaconda.log or boot with ide=nodma.  

If the average person runs into this problem, it is going to stop them
cold.  The above information would go a long way to getting them
started on troubleshooting it. 

Note You need to log in before you can comment on or make changes to this bug.