Bug 137652 - DHCP does not work with eth0:1 device
DHCP does not work with eth0:1 device
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-29 19:21 EDT by David Kaplan
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 11:48:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kaplan 2004-10-29 19:21:35 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
I use several profiles with system-config-network.  In one profile I
have an eth0 device with a static IP address for work.  In another, I
have an eth0:1 device that uses DHCP.  This eth0:1 always fails with
the error:

Determining IP information for eth0:1...SIOCSIFFLAGS: Cannot assign
requested address
SIOCSIFFLAGS: Cannot assign requested address
 failed.

On the other hand, if I change the original eth0 device to DHCP and
activate it, it works without problems and gets assigned an IP address.

Steps to Reproduce:
1. create a second device that uses the same hardware device (eth0). 
This will be called eth0:1.  This device should use DHCP and be in a
separate profile as you can't have multiple devices on the same
hardware device if one uses DHCP.
2. Try to active eth0:1 device
3.
  
Actual results:
Activation fails with the error:

Determining IP information for eth0:1...SIOCSIFFLAGS: Cannot assign
requested address
SIOCSIFFLAGS: Cannot assign requested address
 failed.


Expected results:
Activation should work and device should get an IP address.

Additional info:
Comment 1 Bill Nottingham 2004-10-29 22:36:21 EDT
You can't use DHCP on alias devices, period. It should probably just
keep you from choosing that.
Comment 2 David Kaplan 2004-11-18 18:31:10 EST
Well that is actually a significant problem.  For example, suppose you
have a wireless connection (which I do) and you want to have one
setting for at home that does not use a key and another for the office
that does (or uses a different type of key).  Both interfaces use
DHCP, but only one will work if the other is an alias.  This is a very
common situation I think.  I guess a solution is to force the
interface not to be an alias, but the default is to make one and cause
users to go down the same road I did.
Comment 3 Harald Hoyer 2004-12-07 11:48:51 EST
use profiles
Comment 4 Mustafa Jamil 2004-12-07 15:31:26 EST
I'm sorry, I don't understand.  I'm using FC3, and using profiles.  I
have exactly the situation that was hypothetically described above
(except mine isn't hypothetical).  My eth0 is a wired ethernet
interface that uses DHCP.  This is the only device in the common profile.

Other than that, I have two profiles (Home and Work) to decide what to
do with my wireless interface.  At work, we use WEP and a specific
ESSID.  At home, I'm using no security and a different ESSID.  Both
sites use DHCP.

I set this up through system-config-network.  eth1 was the device for
the Work profile.  eth1:1 was assigned the device for the Home
profile.  Switching to the Home profile and trying to activate the
wireless interface fails.

I have currently worked around the problem by just assigning a static
IP on my home network.  However, this isn't an acceptable solution. 
As a lame road warrior, I'd like to have different profiles that use
DHCP for things like T-Mobile HotSpots.  I don't see how this works.

If I'm doing something wrong, I'd appreciate being told how to set
this up.  Just saying "use profiles" isn't sufficient.
Comment 5 David Kaplan 2004-12-07 16:02:46 EST
You need to set the eth1:1 device to use eth1 instead and then it will
work.  The only drawback to this is that when you activate either your
home or office interface, both will appear as "active" in the
system-config-network display.
Comment 6 David Kaplan 2004-12-07 16:26:39 EST
Harald - I have always used profiles.  This doesn't solve the problem.  

For example, from a blank system-config-network (i.e. no devices),
create a work profile with a single eth0 device that uses a fixed IP
address.  Then create a second home profile and try to create an
ethernet device that uses DHCP.  In the current version of
system-config-network (FC3), when the wizard reaches the configure IP
section, it will not let you choose DHCP because it has already
decided that the device will be eth0:1, an alias, even though the
second device will be in a different profile.  The only way I know of
to fix this is to create the device using a fixed IP address and then
go back, change the device so that it uses eth0 instead of eth0:1 and
then set it to use DHCP.

While this solution works, it has several drawbacks.  For one, it is
really unintuitive and roundabout.  Second, when you activate either
of the eth0 devices, both appear as active in the
system-config-network window.  OK, you could set the fixed IP address
device to use an alias, and this would fix the problem of both
appearing active.  But this solution can't be used if you are using a
wireless device with different keys, as I do, all of which use DHCP.  
Comment 7 Harald Hoyer 2004-12-08 05:48:46 EST
In one profile use eth0 with dhcp.
In the other profile use eth0 with static ips.
You do not have to use aliased devices, only if you want multiple IP
addresses for one interface in the same profile.
Comment 8 Harald Hoyer 2004-12-08 05:51:10 EST
use the copy button, if you want a copy of eth0. Then activate the
copy in one profile and the original in the other..
I know it is not intuitive, and I plan to change the GUI for the
profile thing.

Note You need to log in before you can comment on or make changes to this bug.