Bug 1376575 - omnibus pcp pmda RFEs regarding automation & documentation
Summary: omnibus pcp pmda RFEs regarding automation & documentation
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pcp   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: pcp-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-15 19:00 UTC by Frank Ch. Eigler
Modified: 2019-03-05 04:17 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2019-03-05 04:17:46 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Frank Ch. Eigler 2016-09-15 19:00:43 UTC
Multiple users complain that:

- Many pmdas are not activated when their subrpms are installed,
  even when they don't require configuration and they don't take
  up resources when idle.  These should be auto-.NeedInstall'd.

- Many pmdas man pages are 95% boilerplate.  They should instead
  elaborate the kinds of metrics that are available.

- Many pmdas don't come with pmlogconf files at all.  The particularly
  lightweight ones should not only come with pmlogconf files, but mark
  the key metrics "include" (auto-enabled) for logging.

Comment 1 Frank Ch. Eigler 2016-09-16 15:12:36 UTC
In order to ease centralized logging of remote targets with different pools of pmdas, it would be desirable for the central site to easily get hold of the potential remote pmlogconf files.

Since we don't have a mechanism to upload those from the target pmcd/pmdas to the remote logger, so we need a less automatic facility.

One possibility is to change the pcp packaging system so that the subpackages that contain pmlogconf and/or pmlogger and/or pmmgr to include/require a copy of all the pmlogconf/* fragments from all the pmdas we ship, already installed under $PCP_VAR/.../pmlogconf, as though someone ./Install'd all the pmda's centrally, in "m" monitoring mode only.

Comment 2 Nathan Scott 2019-03-05 04:17:46 UTC
There have been many pcp changes since this BZ was opened, and pcp-zeroconf solves many of the issues in a more practical way than described here.  The description of pmlogconf files in the BZ is also incorrect - for the most part, these reside in the (central) pcp package already.  No further work on this BZ is planned by the pcp team.  However, please feel free to work on any ideas in upstream PCP, and have them filter back via the usual Fedora update mechanisms.


Note You need to log in before you can comment on or make changes to this bug.