Bug 1376630 - IDM admin password gets written to /root/.dogtag/pki-tomcat/ca/pkcs12_password.conf
Summary: IDM admin password gets written to /root/.dogtag/pki-tomcat/ca/pkcs12_passwor...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Abhijeet Kasurde
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-16 00:49 UTC by Fraser Tweedale
Modified: 2017-08-01 09:39 UTC (History)
4 users (show)

Fixed In Version: ipa-4.5.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:39:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2304 normal SHIPPED_LIVE ipa bug fix and enhancement update 2017-08-01 12:41:35 UTC

Description Fraser Tweedale 2016-09-16 00:49:32 UTC
Description of problem:

IDM admin password gets written to /root/.dogtag/pki-tomcat/ca/pkcs12_password.conf during installation.  This file contains the passphrase for a backup of the Dogtag CA Agent certificate and key in
/root/ca-agent.p12.

The file is well protected by file system permissions but if it is
compromised we do not want the actor to get full control over IDM.


Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1. install IPA


Actual results:

The admin user's password appears in file /root/.dogtag/pki-tomcat/ca/pkcs12_password.conf


Expected results:

The admin user's password should not appear in the file.  If an actor gets access to the file, we do not want that actor to pivot to having full
control over IDM.


Additional info:

Proposed fix: randomly generate the password for this backup file.

Comment 4 Abhijeet Kasurde 2017-05-25 09:38:53 UTC
Verified using IPA server version:: ipa-server-4.5.0-13.el7.x86_64


After successful installation no pkcs12_password.conf file found on system.

[root@ipaserver01 ~]# locate pkcs12_password.conf
[root@ipaserver01 ~]# ls /root/.dogtag/pki-tomcat/ca/pkcs12_password.conf
ls: cannot access /root/.dogtag/pki-tomcat/ca/pkcs12_password.conf: No such file or directory

Marking BZ as verified.

Comment 5 errata-xmlrpc 2017-08-01 09:39:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2304


Note You need to log in before you can comment on or make changes to this bug.