Bug 137667 - Sendmail Linked to wrong sasl library
Sendmail Linked to wrong sasl library
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: sendmail (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-30 08:15 EDT by Chetan Dutta
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-26 05:19:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chetan Dutta 2004-10-30 08:15:24 EDT
Description of problem:
Sendmail in RHEL 3.0 is linked to wrong cyrus-sasl library. It should 
be linked to libsasl2.so.2 but it is linked to libsasl.so.7 which is 
an older version of cyrus-sasl.  Because of this, I believe, sendmail 
is not able to communicate with any  cyrus-sasl component. 

Version-Release number of selected component (if applicable):


How reproducible:
Try to configure Sendmail for SMTP AUTH with saslauthd, it will not 
work and you will get the following error in logs:
saslauthd    do_request  : login exceeded MAX_REQ_LEN: 256

Steps to Reproduce:
1.in /usr/lib/sasl2/Sendmail.conf set:
pwcheck_method: saslauthd
2. in /etc/sysconfig/saslauthd set MECH=pam
3. enable authentication while sending  mail in any client and send 
mail, when prompted type in any system username and password.
  
Actual results:
Error message in Logs:
Sendmail: Authentication Failed
saslauthd   do_request   : login exceeded MAX_REQ_LEN: 256

Expected results:
sendmail should accept mail with successful authentication

Additional info:
Comment 1 Thomas Woerner 2004-11-02 04:27:13 EST
sendmail is linked against sasl1, because LDAP is linked against sasl1
and there is a major problem in mixing sasl1 and sasl2.

Closing as "NOT A BUG".
Comment 2 Chetan Dutta 2004-11-02 08:57:04 EST
but then saslauthd should have been linked with sasl1 otherwise how 
can they communicate? the documentation with redhat says i can use 
saslauthd as method in /usr/lib/sasl2/Sendmail.conf
which is not true!
Comment 3 Thomas Woerner 2004-11-02 09:18:52 EST
sasauthd is sasl2 only.

You have to use the sasl1 config file in /usr/lib/sasl/:
pwcheck_method:pam
Comment 4 Chetan Dutta 2004-11-26 03:57:55 EST
i've recompiled sendmail rpm with sasl2, now sendmail works with 
saslauthd as well as ldap. I tried only simple Bind. If this is 
enough indication of sendmail working properly with LDAP, then its 
working!
Comment 5 Thomas Woerner 2004-11-26 05:19:35 EST
Just have a look at:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=124086 and
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=125383

Closing as "NOT A BUG".

Note You need to log in before you can comment on or make changes to this bug.