Bug 1376694 - Disable gluster-NFS post upgrade to >= RHGS 3.2 release
Summary: Disable gluster-NFS post upgrade to >= RHGS 3.2 release
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-nfs
Version: rhgs-3.1
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
: RHGS 3.2.0
Assignee: Jiffin
QA Contact: surabhi
URL:
Whiteboard:
Depends On: 1376692
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-16 07:51 UTC by Soumya Koduri
Modified: 2016-12-16 13:23 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1376692
Environment:
Last Closed: 2016-12-16 13:22:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1368444 0 unspecified CLOSED [Doc RFE]: Changes will be required in upgrade section for 3.2 nfs-ganesha 2021-02-22 00:41:40 UTC

Internal Links: 1368444

Description Soumya Koduri 2016-09-16 07:51:34 UTC
+++ This bug was initially created as a clone of Bug #1376692 +++

Description of problem:

Since gluster-NFS is no more default NFS server for gluster volumes from 3.8.x release, it shouldn't be started by default post upgrade to >=3.8.x releases.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Atin Mukherjee 2016-09-16 18:05:43 UTC
I need to understand the requirement here, if the setup already has an active nfs mount(s) pre upgrade I dont see a reason of disabling the service post upgrade. So in that case would there be a migration path from nfs to nfs ganesha for the existing mounts?

Comment 6 Atin Mukherjee 2016-09-24 07:26:44 UTC
While I was looking at the BZ 1378677 I realized currently we don't start gNFS process in rhgs-3.2.0 post upgrade when earlier gNFS enabled. So I believe we have nothing to do here, can you cross check it Kaleb?

Comment 7 Soumya Koduri 2016-09-24 11:58:39 UTC
But Jiffin observed that when the option "nfs.disable" is explicitly set to off (not by default but if admin manually sets it) for any volume in 3.1.3, after upgrade that option will remain 'off' bringing gluster-NFS server. Jiffin shall be able to confirm it.

Comment 8 Niels de Vos 2016-09-29 14:44:44 UTC
Downstream wants a different approach than upstream:

https://github.com/gluster/glusterfs/blob/release-3.8/doc/release-notes/3.8.0.md#glusternfs-disabled-by-default

> Existing volumes that have gNFS enabled will remain enabled unless explicitly
> disabled.

For downstream all upgrades need to have gNFS disabled, no matter if the admin explicitly enabled gNFS before the upgrade.

Comment 17 Jiffin 2016-11-18 07:12:04 UTC
Patch posted downstream up for review https://code.engineering.redhat.com/gerrit/#/c/90425

Comment 22 Atin Mukherjee 2016-11-21 08:42:43 UTC
(In reply to Jiffin from comment #17)
> Patch posted downstream up for review
> https://code.engineering.redhat.com/gerrit/#/c/90425

Please note this is a downstream only change.

Comment 25 RHEL Program Management 2016-12-15 04:22:52 UTC
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.