Bug 1376729 - ipa-server-install script option --no_hbac_allow should match other options
Summary: ipa-server-install script option --no_hbac_allow should match other options
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Sudhir Menon
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-16 09:24 UTC by Abhijeet Kasurde
Modified: 2017-08-01 09:39 UTC (History)
4 users (show)

Fixed In Version: ipa-4.5.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:39:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2304 normal SHIPPED_LIVE ipa bug fix and enhancement update 2017-08-01 12:41:35 UTC

Description Abhijeet Kasurde 2016-09-16 09:24:08 UTC
Description of problem:
--no_hback_allow option in ipa-server-install contains underscore "_" as opposed to all other options which contains hypen "-"

[root@ipamaster /]# ipa-server-install --help |grep no_
    --no_hbac_allow     Don't install allow_all HBAC rule

Version-Release number of selected component (if applicable):
ipa-server-4.4.0-11.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. ipa-server-install --help | grep no_hbac

Actual results:
Option --no_hbac_allow contains underscore as opposed to all other options 


Expected results:
Replace underscore with hypen

Comment 2 Petr Vobornik 2016-09-16 09:50:45 UTC
This is a very old option.

But I agree that in is not consistent. Any fix should keep the old option for backwards compatibility - it can be hidden in help though. An then new option with proper name created.

Comment 3 Petr Vobornik 2016-09-23 17:04:23 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6357

Comment 4 Martin Bašti 🖰 2016-10-18 15:35:13 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/a42059228018839ae2656c27f5b00d96bc935ee3

Comment 6 Sudhir Menon 2017-05-25 09:52:23 UTC
Tested on RHEL7.4 using

ipa-server-4.5.0-13.el7.x86_64
sssd-1.15.2-35.el7.x86_64
389-ds-base-1.3.6.1-14.el7.x86_64
pki-server-10.4.1-4.el7.noarch
pki-ca-10.4.1-4.el7.noarch
selinux-policy-3.13.1-152.el7.noarch


[root@master ~]# ipa-server-install -no_hbac_allow
Usage: ipa-server-install [options]
ipa-server-install: error: option --domain: only letters, numbers, '-' are allowed. DNS label may not start or end with '-'
ipa.ipapython.install.cli.install_tool(CompatServerMasterInstall): ERROR    The ipa-server-install command failed. See /var/log/ipaserver-install.log for more information

[root@master ~]# ipa-server-install --no-hbac-allow
Configuring testrelm.test as NIS domain.
Client configuration complete.
The ipa-client-install command was successful

Comment 7 errata-xmlrpc 2017-08-01 09:39:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2304


Note You need to log in before you can comment on or make changes to this bug.