Bug 137687 - qt-devel requires XFree86-devel (incorrect)
Summary: qt-devel requires XFree86-devel (incorrect)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: qt   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-30 18:20 UTC by Philippe Rigault
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-31 20:35:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Philippe Rigault 2004-10-30 18:20:32 UTC
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, 
like Gecko) 
 
Description of problem: 
qt-devel requires XFree86-devel (incorrect) instead of xorg-x11-devel 
(correct) 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. rpm -qp --requires qt-devel-3.3.3-8.i386.rpm 
   
 
Actual Results:  XFree86-devel 
... 
 
 
Expected Results:  xorg-x11-devel 
... 
 
 
Additional info: 
 
This can confuse users and break scripts dealing with dependencies 
 
For example: 
# rpm -i qt-devel-3.3.3-8.i386.rpm 
error: Failed dependencies: 
        XFree86-devel is needed by qt-devel-3.3.3-8.i386.rpm 
 
There is no XFree86-devel rpm file -> user thinks he/she is stuck 
 
Creative/advanced user knows that xorg-x11-devel provides 
XFree86-devel--in other words, the solution is: 
# rpm -i xorg-x11-devel-6.8.1-12.i386.rpm 
# rpm -i qt-devel-3.3.3-8.i386.rpm 
but I doubt that most users would find this easily. 
 
Since qt-devel is required to build a kernel with 'make xconfig', a 
lot of people will run into this.

Comment 1 Ngo Than 2004-10-31 20:35:02 UTC
it's fixed in 3.3.3-9. Thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.