Bug 137690 - rpm file conflicts are off
Summary: rpm file conflicts are off
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
: 131766 (view as bug list)
Depends On:
Blocks: FC3Blocker
TreeView+ depends on / blocked
 
Reported: 2004-10-30 18:59 UTC by Nathan G. Grennan
Modified: 2007-11-30 22:10 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 14:02:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nathan G. Grennan 2004-10-30 18:59:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Galeon/1.3.17.99

Description of problem:
Two installed packages own the files in the same directories largely
defeats the point of package management. It is likely to cause broken
applications in many cases. Say two Gnome packages use the same
library, but want to compiled with different options. So that their
own versions of the file are mutally exclusive. So package A was
installed and working. Package B is installed and overwrites
/usr/lib/libgnomefoo.so.1. Now application B works and application A
doesn't.

Version-Release number of selected component (if applicable):
rpm-4.3.2-13

How reproducible:
Always

Steps to Reproduce:
1. rpm -i packagea.rpm
2. rpm -i packageb.rpm

    

Actual Results:  File conflicts by default

Expected Results:  No file conflicts by default

Additional info:

"RPM's default behavior regarding file conflicts in Fedora Core 3 has
changed. In the past, file conflicts (where a file from one
already-installed package also appears in a package that is to be
installed) caused the installation of the package containing the
conflicting file to abort.

In Fedora Core 3, RPM will ignore such conflicts, and the package
installation will proceed, overwriting any conflicting files from
previously-installed packages."

Comment 1 Nathan G. Grennan 2004-10-30 19:06:17 UTC
I got Actual and Expected Results reversed.

This default change could also have negative security effects.

Comment 2 Jeff Johnson 2004-10-31 08:29:39 UTC
File conflicts reenabled by default in rpm-4.3.2-18.

Comment 3 Warren Togami 2004-10-31 10:41:48 UTC
REOPEN because it was not built in dist-fc3-HEAD, but rather dist-fc4.
 rel-eng will need to accept this in order for this bug to be closed.

Comment 4 Warren Togami 2004-10-31 10:52:16 UTC
*** Bug 131766 has been marked as a duplicate of this bug. ***

Comment 5 Robert Scheck 2004-10-31 11:01:44 UTC
Copy Warren :)

Comment 6 Cristian Gafton 2004-10-31 12:30:47 UTC
Fix summary to show better in the dependency list for the FC3Blocker.

Warren, please be careful when closing bugs as duplicate (you should
have closed this bug as duplicate and left #131766 alone, since that
was the older one filed)

Comment 14 Dax Kelson 2004-11-01 04:37:41 UTC
I'm glad this change was reverted. 


Note You need to log in before you can comment on or make changes to this bug.