Bug 1376939 - zathura doesn't use config settings for statusbar from config file
Summary: zathura doesn't use config settings for statusbar from config file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: zathura
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Šabata
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-16 21:38 UTC by Lokesh Mandvekar
Modified: 2017-01-25 00:20 UTC (History)
3 users (show)

Fixed In Version: zathura-0.3.7-1.fc25 zathura-0.3.7-1.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-24 23:20:04 UTC


Attachments (Terms of Use)
no-file-open (30.19 KB, image/png)
2016-09-20 13:31 UTC, Lokesh Mandvekar
no flags Details
file-open (199.67 KB, image/png)
2016-09-20 13:33 UTC, Lokesh Mandvekar
no flags Details

Description Lokesh Mandvekar 2016-09-16 21:38:21 UTC
Description of problem:

My ~/config/zathura/zathurarc:

set adjust-open "width"
set default-bg "#222222"
set default-fg "#dddddd"
set font "Fixed 10"
set inputbar-bg "#222222"
set inputbar-fg "#dddddd"
set statusbar-bg "#222222"
set statusbar-fg "#dddddd"
set completion-bg "#222222"
set completion-fg "#dddddd"
set show-scrollbars false
set recolor true
set recolor-darkcolor "#dddddd"
set recolor-lightcolor "#222222"

RE: statusbar settings, I'd expect a black bg and white fg, but it seems to load a transparent bg and black fg. Transparent because once my pdf loads, the statusbar becomes black-on-black.

Version-Release number of selected component (if applicable): zathura-0.3.6-1.fc25.x86_64


How reproducible: always

Comment 1 Lokesh Mandvekar 2016-09-16 21:39:11 UTC
(In reply to Lokesh Mandvekar from comment #0)
> Description of problem:
> 
> My ~/config/zathura/zathurarc:

I meant ~/.config/zathura/zathurarc of course.

Comment 2 Petr Šabata 2016-09-20 13:09:51 UTC
Curious.  I cannot reproduce this on F24.

zathura-0.3.6-1.fc24.x86_64
girara-0.2.6-1.fc24.x86_64

Does this happen with every PDF document or just some?
Are you running X or Wayland?

I'll test in an F25 VM.

Comment 3 Lokesh Mandvekar 2016-09-20 13:31:11 UTC
Created attachment 1202889 [details]
no-file-open

screenshot when no file is open. status bar has black text (I'd expect white). I'm not sure what the default background used to look like when the settings worked, but I'd expect it to be black and not white.

Comment 4 Lokesh Mandvekar 2016-09-20 13:33:51 UTC
Created attachment 1202891 [details]
file-open

see screenshot when a file is open. The pdf text and bg are white on black as expected. But notice the text in the bottom left, "62.8" is overwritten by the status bar content.

Comment 5 Lokesh Mandvekar 2016-09-20 13:34:10 UTC
I'm using X btw.

Comment 6 Lokesh Mandvekar 2016-09-20 13:36:03 UTC
Also, this happens consistently, regardless of pdf opened.

Comment 7 Petr Pisar 2016-09-21 07:42:48 UTC
Gnome team rebased gtk3 recently.

Comment 8 Petr Šabata 2016-10-13 09:56:24 UTC
Confirmed on F25b.

Comment 9 Petr Šabata 2016-10-24 11:46:46 UTC
(In reply to Petr Pisar from comment #7)
> Gnome team rebased gtk3 recently.

This was a good hint.

I confirm this happens with gtk3-3.22.1-2.fc25 but not with gtk3-3.20.9-1.fc25 (custom built from f24 git repos).

Comment 10 Petr Šabata 2017-01-16 01:01:53 UTC
This should be fixed in girara 0.2.7.

Comment 11 Fedora Update System 2017-01-16 01:02:43 UTC
girara-0.2.7-1.fc25 zathura-0.3.7-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-b05153ba1d

Comment 12 Fedora Update System 2017-01-16 01:03:02 UTC
girara-0.2.7-1.fc24 zathura-0.3.7-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-484e06b4cc

Comment 13 Fedora Update System 2017-01-16 22:22:28 UTC
girara-0.2.7-1.fc24, zathura-0.3.7-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-484e06b4cc

Comment 14 Fedora Update System 2017-01-16 22:23:03 UTC
girara-0.2.7-1.fc25, zathura-0.3.7-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-b05153ba1d

Comment 15 Fedora Update System 2017-01-24 23:20:04 UTC
girara-0.2.7-1.fc25, zathura-0.3.7-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2017-01-25 00:20:55 UTC
girara-0.2.7-1.fc24, zathura-0.3.7-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.