Bug 137694 - gnumeric produces LaTeX output is using macros which were not defined
gnumeric produces LaTeX output is using macros which were not defined
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnumeric (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-30 15:42 EDT by Michal Jaegermann
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-09 13:29:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-10-30 15:42:30 EDT
Description of problem:

At least on some files gnumeric is producing LaTeX output
where some used macros, more precisely control sequences,
were previously undefined.

Version-Release number of selected component (if applicable):
gnumeric-1.2.13-6

How reproducible:
Some inputs

Steps to Reproduce:
1. Take an Excel file from an attachment to bug #137692
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=105981&action=view
and save as Velvia.xls

2. Load Velvia.xls into gnumeric and save as "LaTeX" file Velvia.tex.
Filter results

   tr -dc '[:print:]\n' < Velvia.tex > Velvia2.tex

or LaTeX will be quite unhappy.
    
3. Do 'latex Velvia2.tex' and watch
! Undefined control sequence.
\@nextchar ...cColJ +\gnumericColK +\gnumericColL 
                                                  +\gnumericColM 

and so on.  The problem is that \gnumericColL, \gnumericColM and
\gnumericColN are used but only \gnumericColA to \gnumericColK
are defined.

Expected results:
All of the above are defined in output before an attempt
to use these.
Comment 1 Michal Jaegermann 2004-10-30 18:48:20 EDT
This bug, as opposed to bug #137692, is platform independent.
Comment 2 Caolan McNamara 2004-11-01 14:16:49 EST
Upstreamed as http://bugzilla.gnome.org/show_bug.cgi?id=157047
Comment 3 Andreas J. Guelzow 2004-11-01 17:18:00 EST
fixed in gnumeric 1.3.92
Comment 4 Caolan McNamara 2004-11-02 07:39:07 EST
backported to rawhide and fc3
Comment 5 Caolan McNamara 2004-11-09 13:29:32 EST
should be good in gnumeric-1.2.13-8.fc3

Note You need to log in before you can comment on or make changes to this bug.