Bug 1376942 - '_get_device_info: device not found.' warning when deleting snapshot volumes
Summary: '_get_device_info: device not found.' warning when deleting snapshot volumes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Alasdair Kergon
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-16 22:01 UTC by Corey Marthaler
Modified: 2016-11-04 04:19 UTC (History)
9 users (show)

Fixed In Version: lvm2-2.02.165-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 04:19:03 UTC
Target Upstream Version:


Attachments (Terms of Use)
verbose snapshot lvremove (99.67 KB, text/plain)
2016-09-19 14:40 UTC, Corey Marthaler
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1445 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2016-11-03 13:46:41 UTC

Description Corey Marthaler 2016-09-16 22:01:30 UTC
Description of problem:
This was mentioned in bug 1368272, but wasn't a part of the fix. This message also existed in the past for cache volumes in bug 1160903.

I believe this was introduced in either 164-2 164-3.


[root@host-117 ~]# lvcreate -s test/linear -L 10M
  Using default stripesize 64.00 KiB.
  Rounding up size to full physical extent 12.00 MiB
  Logical volume "lvol0" created.

[root@host-117 ~]# lvs -a -o +devices
  LV     VG            Attr       LSize   Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert Devices
  linear test          owi-aos--- 100.00m                                                     /dev/sda1(0)
  lvol0  test          swi-a-s---  12.00m      linear 0.00                                    /dev/sda1(25)

[root@host-117 ~]# lvremove test/lvol0
Do you really want to remove active logical volume test/lvol0? [y/n]: y
  _get_device_info: LVM-mqdegc3xzEXA4RYCnFHf3xfU4i9L4lBJLZ6OvJcrljWgv33B70vrzt4hjoUDvVip: device not found.
  Logical volume "lvol0" successfully removed



Version-Release number of selected component (if applicable):
lvm2-2.02.164-3.el7    BUILT: Wed Aug 24 05:20:41 CDT 2016
lvm2-libs-2.02.164-3.el7    BUILT: Wed Aug 24 05:20:41 CDT 2016
lvm2-cluster-2.02.164-3.el7    BUILT: Wed Aug 24 05:20:41 CDT 2016
device-mapper-1.02.133-3.el7    BUILT: Wed Aug 24 05:20:41 CDT 2016
device-mapper-libs-1.02.133-3.el7    BUILT: Wed Aug 24 05:20:41 CDT 2016
device-mapper-event-1.02.133-3.el7    BUILT: Wed Aug 24 05:20:41 CDT 2016
device-mapper-event-libs-1.02.133-3.el7    BUILT: Wed Aug 24 05:20:41 CDT 2016
device-mapper-persistent-data-0.6.3-1.el7    BUILT: Fri Jul 22 05:29:13 CDT 2016

Comment 2 Corey Marthaler 2016-09-19 14:40:59 UTC
Created attachment 1202518 [details]
verbose snapshot lvremove

Additional info about this snap remove, including messages on console:

Sep 19 09:31:14 host-117 lvm[8823]: Target linear is not snapshot.
Sep 19 09:31:14 host-117 lvm[8823]: device-mapper: waitevent ioctl on LVM-aX3hxuETUrUwHYncqnBWa3LMT5Mx4dNineT0Ncm3W264k0TmiJLYgf4eKNAZcC1T failed: No such device or address
Sep 19 09:31:14 host-117 lvm[8823]: test-lvol0 disappeared, detaching.
Sep 19 09:31:14 host-117 multipathd: test-lvol0: adding map
Sep 19 09:31:14 host-117 multipathd: test-lvol0: devmap dm-5 added
Sep 19 09:31:14 host-117 multipathd: dm-5: remove map (uevent)
Sep 19 09:31:14 host-117 multipathd: dm-5: devmap not registered, can't remove
Sep 19 09:31:14 host-117 multipathd: dm-5: remove map (uevent)


#libdm-deptree.c:2706     Loading test-linear table (253:2)
#libdm-deptree.c:2650         Adding target to (253:2): 0 204800 linear 8:1 2048
#ioctl/libdm-iface.c:1838         dm table   (253:2) [ opencount flush ]   [16384] (*1)
#ioctl/libdm-iface.c:1838         dm reload   (253:2) [ noopencount flush ]   [16384] (*1)
#activate/dev_manager.c:3107         Creating PRELOAD tree for test/lvol0.
#activate/dev_manager.c:1759         Getting device info for test-lvol0 [LVM-aX3hxuETUrUwHYncqnBWa3LMT5Mx4dNineT0Ncm3W264k0TmiJLYgf4eKNAZcC1T]
#ioctl/libdm-iface.c:1838         dm info  LVM-aX3hxuETUrUwHYncqnBWa3LMT5Mx4dNineT0Ncm3W264k0TmiJLYgf4eKNAZcC1T [ opencount flush ]   [16384] (*1)
#ioctl/libdm-iface.c:1838         dm deps   (253:5) [ opencount flush ]   [16384] (*1)
#ioctl/libdm-iface.c:1838         dm deps   (253:4) [ opencount flush ]   [16384] (*1)
#ioctl/libdm-iface.c:1838         dm deps   (253:3) [ opencount flush ]   [16384] (*1)
#activate/dev_manager.c:1759         Getting device info for test-lvol0-real [LVM-aX3hxuETUrUwHYncqnBWa3LMT5Mx4dNineT0Ncm3W264k0TmiJLYgf4eKNAZcC1T-real]
#ioctl/libdm-iface.c:1838         dm info  LVM-aX3hxuETUrUwHYncqnBWa3LMT5Mx4dNineT0Ncm3W264k0TmiJLYgf4eKNAZcC1T-real [ opencount flush ]   [16384] (*1)
#activate/dev_manager.c:1759         Getting device info for test-lvol0-cow [LVM-aX3hxuETUrUwHYncqnBWa3LMT5Mx4dNineT0Ncm3W264k0TmiJLYgf4eKNAZcC1T-cow]
#ioctl/libdm-iface.c:1838         dm info  LVM-aX3hxuETUrUwHYncqnBWa3LMT5Mx4dNineT0Ncm3W264k0TmiJLYgf4eKNAZcC1T-cow [ opencount flush ]   [16384] (*1)
#libdm-deptree.c:574         Matched uuid LVM-aX3hxuETUrUwHYncqnBWa3LMT5Mx4dNineT0Ncm3W264k0TmiJLYgf4eKNAZcC1T in deptree.
#libdm-deptree.c:574         Matched uuid LVM-aX3hxuETUrUwHYncqnBWa3LMT5Mx4dNineT0Ncm3W264k0TmiJLYgf4eKNAZcC1T in deptree.
#activate/dev_manager.c:2679         Checking kernel supports striped segment type for test/lvol0
#metadata/metadata.c:2623         Calculated readahead of LV lvol0 is 8192
#libdm-deptree.c:2706     Loading test-lvol0 table (253:5)
#libdm-deptree.c:2650         Adding target to (253:5): 0 24576 linear 8:1 206848
#ioctl/libdm-iface.c:1838         dm table   (253:5) [ opencount flush ]   [16384] (*1)
#ioctl/libdm-iface.c:1838         dm reload   (253:5) [ noopencount flush ]   [16384] (*1)
#libdm-deptree.c:2759         Table size changed from 204800 to 24576 for test-lvol0 (253:5).
#libdm-config.c:950       dmeventd/executable not found in config: defaulting to /usr/sbin/dmeventd
#ioctl/libdm-iface.c:1838         dm info  LVM-aX3hxuETUrUwHYncqnBWa3LMT5Mx4dNiRC9dsr4dODC51aDc5dV6I7IhTuXTwFKv [ opencount flush ]   [16384] (*1)
#libdevmapper-event.c:591   _get_device_info: LVM-aX3hxuETUrUwHYncqnBWa3LMT5Mx4dNiRC9dsr4dODC51aDc5dV6I7IhTuXTwFKv: device not found.
#libdevmapper-event.c:750         Device does not exists (uuid=LVM-aX3hxuETUrUwHYncqnBWa3LMT5Mx4dNiRC9dsr4dODC51aDc5dV6I7IhTuXTwFKv, name=(null), 0:0).
#activate/activate.c:1857     test/lvol0 already not monitored.
#mm/memlock.c:582         Entering critical section (suspending).
#mm/memlock.c:551         Lock:   Memlock counters: locked:0 critical:1 daemon:0 suspended:0
#mm/memlock.c:475       Locking memory
#libdm-config.c:1036       Setting activation/use_mlockall to 0

Comment 3 Alasdair Kergon 2016-09-19 14:51:40 UTC
Reproduced.

Comment 4 Alasdair Kergon 2016-09-19 15:29:08 UTC
It's using the wrong uuid, from the internal snapshot LV instead of the cow.  Regression. Easily fixed I think.

Comment 7 Corey Marthaler 2016-09-21 19:12:40 UTC
Fix verified in the latest rpms. No longer seeing this message in any of the snap shot regression scenarios.


3.10.0-501.el7.x86_64
lvm2-2.02.165-3.el7    BUILT: Wed Sep 21 08:26:18 CDT 2016
lvm2-libs-2.02.165-3.el7    BUILT: Wed Sep 21 08:26:18 CDT 2016
lvm2-cluster-2.02.165-3.el7    BUILT: Wed Sep 21 08:26:18 CDT 2016
device-mapper-1.02.134-3.el7    BUILT: Wed Sep 21 08:26:18 CDT 2016
device-mapper-libs-1.02.134-3.el7    BUILT: Wed Sep 21 08:26:18 CDT 2016
device-mapper-event-1.02.134-3.el7    BUILT: Wed Sep 21 08:26:18 CDT 2016
device-mapper-event-libs-1.02.134-3.el7    BUILT: Wed Sep 21 08:26:18 CDT 2016
device-mapper-persistent-data-0.6.3-1.el7    BUILT: Fri Jul 22 05:29:13 CDT 2016



[root@host-130 ~]# lvcreate -s test/linear -L 10M
  Using default stripesize 64.00 KiB.
  Rounding up size to full physical extent 12.00 MiB
  Logical volume "lvol0" created.

[root@host-130 ~]# lvremove test/lvol0
Do you really want to remove active logical volume test/lvol0? [y/n]: y
  Logical volume "lvol0" successfully removed

Comment 9 errata-xmlrpc 2016-11-04 04:19:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1445.html


Note You need to log in before you can comment on or make changes to this bug.