Bug 137701 - Machine won't shutdown after /sbin/poweroff execution
Summary: Machine won't shutdown after /sbin/poweroff execution
Status: CLOSED DUPLICATE of bug 132761
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 3
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-30 21:55 UTC by Jure
Modified: 2015-01-04 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 19:35:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jure 2004-10-30 21:55:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
After calling /sbin/poweroff the machine goes to runlevel 6, 
it stops all services and disks and then halts. The last message on 
the screen is: acpi_poweroff_called.
Machine waits in this state until the power off button is pressed.

The strange thing about this is, that the problem occurred after
updating kernel package from 2.6.8-xxxx to current release (2.6.9-1.649).

My machine is ASUS M2400N laptop. (Intel Centrino 1.3Ghz)








Version-Release number of selected component (if applicable):
kernel-2.6.9-1.649

How reproducible:
Always

Steps to Reproduce:
1./sbin/poweroff
2.
3.
    

Additional info:

Comment 1 Stefan Hoelldampf 2004-10-31 19:38:33 UTC
Seems to be related to bug acpi_power_off (bug 132761)

Comment 2 Dave Jones 2004-11-01 19:35:03 UTC

*** This bug has been marked as a duplicate of 132761 ***

Comment 3 Jérémy Kermorvant 2004-11-14 18:17:45 UTC
Hi,

this is a workaroung about this issue :

Modification file : grub.conf (/boot/grub)

in current line you have :
kernel /vmlinuz-2.6.9-1.667 ro root=/dev/VolGroup00/LogVol00 rhgb quiet

after mofication : 
kernel /vmlinuz-2.6.9-1.667 ro root=/dev/VolGroup00/LogVol00 acpi=off
rhgb quiet

procedure to modify the file :
-1- in root mode
-2- cd /boot/grub
-3- edit the file grub.conf
-4- add before rhgb quiet acpi=off
-5- save the file
-6- reboot the system to take the modification

Problem solve on my laptop with AMD CPU

Best Regards

Jeremy


Note You need to log in before you can comment on or make changes to this bug.