Bug 137703 - USB multi-card reader is not being recognized
USB multi-card reader is not being recognized
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-30 18:56 EDT by Ian Burrell
Modified: 2015-01-04 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-19 23:45:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to kernel to add multi LUN for SIIG card reader (562 bytes, patch)
2004-11-02 00:02 EST, Ian Burrell
no flags Details | Diff

  None (edit)
Description Ian Burrell 2004-10-30 18:56:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
Only the first slot of a USB 6-in-1 flash reader is being recognized
by the kernel.

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.649

How reproducible:
Always

Steps to Reproduce:
1. Plug in flash reader
2. Insert MemoryStick in slot

Actual Results:  The Memory Stick is not recognized.  The logs show
that only one slot is being recognized for the device.


Expected Results:  Only six slot should have separate devices created.
 The Memory Stick slot should recognize and mount when a card is inserted

Additional info:

Adding "options scsi_mod max_luns=6" to /etc/modprobe.conf causes all
6 slots to be recognized.  It would be nice if it was recognized
automatically.

From /proc/scsi/scsi:

Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: generic  Model: USB Storage-SMC  Rev: 0207
  Type:   Direct-Access                    ANSI SCSI revision: 02

From /proc/scsi/usb-storage/0:

   Host scsi0: usb-storage
       Vendor: Generic
      Product: USB Storage Device
Serial Number: 20000124093703870
     Protocol: Transparent SCSI
    Transport: Bulk
       Quirks:
Comment 1 Dave Jones 2004-11-01 14:37:00 EST
Vendor: generic  Model: USB Storage-SMC  Rev: 0207

Is this line _exactly_ as it appears ? The reason I ask, is I have
an identical device, but mine shows up as "Generic" instead of "generic".
Comment 2 Ian Burrell 2004-11-01 23:45:14 EST
That is exactly how it appears in the scsi devices, with the lowercase
"generic" for the vendor.  It sounds like this chip (Neodio ND3050) is
used in many generic readers.  Mine is made by SIIG.  

lsusb says:

Bus 001 Device 003: ID 0aec:3050 Neodio Technologies Corp.
Comment 3 Ian Burrell 2004-11-02 00:01:38 EST
Some more investigation showed that the case of the vendor is what
makes the difference.  I did:

echo 'generic:USB Storage-SMC:0x2' > /proc/scsi/device_info

And then the kernel recognizes the 4 slots as /dev/sda to /dev/sdd.
Comment 4 Ian Burrell 2004-11-02 00:02:58 EST
Created attachment 106059 [details]
Patch to kernel to add multi LUN for SIIG card reader
Comment 5 Dave Jones 2004-11-03 20:47:36 EST
fixed in cvs.
Comment 6 Dave Jones 2004-11-19 23:45:40 EST
fixed in update.

Note You need to log in before you can comment on or make changes to this bug.