Bug 137704 - php cli required
Summary: php cli required
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: php   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-30 23:31 UTC by Karl Latiss
Modified: 2007-11-30 22:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-14 13:59:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
php.spec patch adding php-cli (1.40 KB, patch)
2004-12-28 12:24 UTC, Karl Latiss
no flags Details | Diff
patch off of 4.3.10-3.2 to add php cli binary (1.41 KB, patch)
2005-03-19 18:40 UTC, Edward Rudd
no flags Details | Diff

Description Karl Latiss 2004-10-30 23:31:04 UTC
Description of problem:
An increasing number of web applications are relying on the PHP CLI
for installation and maintenance. While the CGI version can be used to
run some of these scripts with appropriate modifications this is only
a workaround.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Suzanne Hillman 2004-11-08 17:23:54 UTC
Is this intended to be filed against RHEL3? I cannot tell which version of RHEL
based on the version above.

Comment 2 Karl Latiss 2004-11-08 23:28:50 UTC
Yes, intended for RHEL3.

Comment 3 Suzanne Hillman 2004-11-09 19:38:22 UTC
Internal RFE bug #138529 entered; will be considered for future releases.

Comment 4 Karl Latiss 2004-12-28 12:24:14 UTC
Created attachment 109146 [details]
php.spec patch adding php-cli

simple patch to php.spec from RHEL PHP version 4.3.2-19.ent to also create CLI
version

Comment 5 Mikkel Kruse Johnsen 2005-03-09 14:11:31 UTC
This also applies to RHEL4. Please make a php-cli package, so we can run all
those php scripts out there.

Comment 6 Edward Rudd 2005-03-11 18:09:36 UTC
Also for Fedora Core, it's rather frustrating when I try to run and develop CLI
apps and they do not work correctly at all in the PHP CGI binary.

Comment 7 Edward Rudd 2005-03-19 18:40:56 UTC
Created attachment 112150 [details]
patch off of 4.3.10-3.2 to add php cli binary

This patch installs the CLI binary as /usr/bin/php and the CGI binary as
php-cgi.

Comment 9 nathan r. hruby 2005-06-27 14:20:19 UTC
METOO.  Minimally, having a man page would be just *super* :)

Comment 10 Karl Latiss 2005-06-28 00:56:18 UTC
looks like FC4 now includes the CLI php binary so I presume it will show up in
RHEL 5

Comment 11 Joe Orton 2005-09-14 13:59:42 UTC
Yes, thanks to Eddie for supplying the patch; this will be included in RHEL5.

This feature is added for the next release of Red Hat Enterprise Linux.  Red Hat
does not currently plan to provide a resolution for this in a Red Hat Enterprise
Linux update for currently deployed systems.

With the goal of minimizing risk of change for deployed systems, and in response
to customer and partner requirements, Red Hat takes a conservative approach when
evaluating changes for inclusion in maintenance updates for currently deployed
products. The primary objectives of update releases are to enable new hardware
platform support and to resolve critical defects. 


Note You need to log in before you can comment on or make changes to this bug.