Bug 1377081 - virt-p2v manual should update the new dialog information
Summary: virt-p2v manual should update the new dialog information
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs
Version: 7.3
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard: P2V
Depends On: 1359086
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-18 08:56 UTC by tingting zheng
Modified: 2017-08-01 22:11 UTC (History)
5 users (show)

Fixed In Version: libguestfs-1.36.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 22:11:26 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2023 normal SHIPPED_LIVE libguestfs bug fix and enhancement update 2017-08-01 19:32:01 UTC

Description tingting zheng 2016-09-18 08:56:28 UTC
Description:
virt-p2v manual should update the new dialog information

Version:
virt-v2v-1.32.7-3.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Check virt-p2v manual:
For the bottom of the dialog part,on rhel7.3,virt-p2v has been added "XTerm" button,so in p2v manual it should update to add the information.

At the bottom of the dialog are these buttons:

        │                                                        │
        │                [ Test connection ]                     │
        │                                                        │
        │ [ Configure network ] [ About virt-p2v  ] [ Next     ] │
        │                                                        │
        └────────────────────────────────────────────────────────┘

Actual results:
As description.

Expected results:
At the bottom of the dialog are these buttons:

        │                                                                │
        │                [ Test connection ]                             │
        │                                                                │
        │ [ Configure network ] [XTerm] [ About virt-p2v  ] [ Next     ] │
        │                                                                │
        └────────────────────────────────────────────────────────────────┘


Additional info:
Minor issue,can leave to rhel7.4.

Comment 2 Richard W.M. Jones 2016-09-19 11:55:03 UTC
Fixed upstream in commits:

2e9d0588818a1b24ca617057a6a51f198fe6505d
21a201051dd42c5433a68a036461dc3d53c16fe1

Comment 4 mxie@redhat.com 2017-03-17 09:58:36 UTC
I can reproduce the bug with build:
virt-v2v-1.32.7-3.el7.x86_64

Verify the bug with build:
virt-v2v-1.36.2-2.el7.x86_64

Steps:
1.Check  dialog part of p2v GUI in virt-p2v man page:

 At the bottom of the dialog are these buttons:

        │                                                             │
        │                     [ Test connection ]                     │
        │                                                             │
        │ [ Configure network ] [ XTerm ] [ About virt-p2v ] [ Next ] │
        │                                                             │
        └─────────────────────────────────────────────────────────────┘

       ......

       The "XTerm" button opens a shell which can be used for diagnostics, manual network configuration, and so on.


Result:
The version 1.36.2 of p2v man page has added button "XTerm" and has a short introduction for it, the bug has been fixed


So move the bug from ON_QA to VERIFIED

Comment 5 errata-xmlrpc 2017-08-01 22:11:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2023


Note You need to log in before you can comment on or make changes to this bug.