Bug 137711 - Yum can't install noarch rpm due to py keyerror
Yum can't install noarch rpm due to py keyerror
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-10-31 01:37 EST by P Jones
Modified: 2014-01-21 17:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 15:13:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description P Jones 2004-10-31 01:37:46 EST
Description of problem:
Yum can't install noarch rpm due to py keyerror

Version-Release number of selected component (if applicable):
yum-2.1.11-2

How reproducible:
always

Steps to Reproduce:
1.rpm -e selinux-policy-targeted
2.yum install selinux-policy-targeted
  
Actual results:
Setting up Install Process
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3426/3426
Traceback (most recent call last):
  File "/usr/bin/yum", line 8, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 68, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 374, in doCommands
    return self.installPkgs()
  File "/usr/share/yum-cli/cli.py", line 734, in installPkgs
    pkglist = returnBestPackages(toBeInstalled)
  File "/usr/lib/python2.3/site-packages/yum/packages.py", line 123,
in returnBestPackages
    elif rpmUtils.arch.isMultiLibArch(arch=a):
  File "/usr/lib/python2.3/site-packages/rpmUtils/arch.py", line 69,
in isMultiLibArch
    if multilibArches.has_key(arches[arch]):
KeyError: 'noarch'
[root:~] #

Expected results:
Yum to download and install the package.

Additional info:
Comment 1 Seth Vidal 2004-10-31 01:46:37 EST
it's been fixed upstream

see bug: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=135396

and apply ONLY the final patch that was attached.
Comment 2 Warren Togami 2004-10-31 10:22:25 EST
CLOSED -> UPSTREAM is bad, it makes this resolution that must be
applied to FC's yum disappear from queries.  REOPENING.

Note You need to log in before you can comment on or make changes to this bug.