Bug 137721 - vte corruption in -7 or -8
vte corruption in -7 or -8
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: 135876
  Show dependency treegraph
 
Reported: 2004-10-31 07:19 EST by Warren Togami
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 16:08:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2004-10-31 07:19:19 EST
Description of problem:
0.11.11-7
- Add support for "scroll-up" and "scroll-down" control 
  sequences to make vte more xterm compatible (Patch
  from Nalin, #128375)
0.11.11-8
- Commit patch from Owen to avoid scrolling invalid regions.

One of these two changes causes gnome-terminal to fail to render stuff
when doing various operations in bash.  Various behaviors are readily
apparent, although not all occuring at the same time:

* All bash prompts scrolled up above the current prompt are replaced
by a black cursor-looking character.
* Seemingly random text that has scrolled past does not render.
* Sometimes the prompt or current line does not render.

Unable to take a screenshot of this since ALT-TAB or screenshot seems
to cause a redraw, fixing the current screen output.  Further activity
however immediately causes more corruption.
Comment 1 Ray Strode [halfline] 2004-11-01 16:08:53 EST
I've pulled the patch out for now.  I'll investigate it more later.

Note You need to log in before you can comment on or make changes to this bug.