Bug 1377278 - undercloud installation request for stack password in cli
Summary: undercloud installation request for stack password in cli
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 10.0 (Newton)
Assignee: James Slagle
QA Contact: Raviv Bar-Tal
URL:
Whiteboard:
Depends On:
Blocks: 1335596 1356451
TreeView+ depends on / blocked
 
Reported: 2016-09-19 11:23 UTC by Raviv Bar-Tal
Modified: 2016-12-14 16:02 UTC (History)
19 users (show)

Fixed In Version: python-openstackclient-3.2.0-2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:02:35 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 364518 None None None 2016-09-19 17:16:49 UTC
OpenStack gerrit 372712 None None None 2016-09-19 19:15:33 UTC
Launchpad 1619274 None None None 2016-09-19 17:16:23 UTC

Description Raviv Bar-Tal 2016-09-19 11:23:53 UTC
Description of problem:
after running the command 'openstack undercloud  --debug --log-file=undercloud_install.log install'
Installation pause until user enter stack password

Version-Release number of selected component (if applicable):


How reproducible:
Run undercloud installation (os 7.3_beta)

Steps to Reproduce:
1.Run undercloud installation (os 7.3_beta)
2.
3.

Actual results:
Auth plugin password selected
auth_config_hook(): {'auth_type': 'password', 'beta_command': False, 'tripleoclient_api_version': '1', u'compute_api_version': u'2', 'key': None, u'database_api_version': u'1.0', u'metering_api_version': u'2', 'inspector_api_version': '1', u'network_api_version': u'2', u'message': u'', u'image_format': u'qcow2', 'networks': [], u'image_api_version': u'2', 'verify': True, u'dns_api_version': u'2', u'object_store_api_version': u'1', u'status': u'active', 'verbose_level': 3, 'region_name': '', 'api_timeout': None, u'baremetal_api_version': '1.6', 'auth': {}, 'default_domain': 'default', 'debug': True, u'image_api_use_tasks': False, u'floating_ip_source': u'neutron', u'orchestration_api_version': '1', 'timing': False, 'cacert': None, u'key_manager_api_version': u'v1', 'workflow_api_version': '2', 'deferred_help': False, u'identity_api_version': u'2.0', u'volume_api_version': u'2', 'cert': None, u'secgroup_source': u'neutron', u'container_api_version': u'1', 'log_file': u'undercloud_install.log', u'interface': None, u'disable_vendor_agent': {}}
Password:

Expected results:


Additional info:

Comment 2 Steve Linabery 2016-09-19 13:55:13 UTC
Just noting that in my manual install environment hitting 'ENTER' at this prompt (i.e. without password) allowed the install to proceed successfully.

Comment 3 Alexander Chuzhoy 2016-09-19 17:05:44 UTC
workaround for scripted deployment:
yes ""| openstack undercloud deploy

Comment 4 James Slagle 2016-09-19 17:17:46 UTC
this should be fixed upstream in python-openstackclient. maybe we just need an updated version of that downstream.

Comment 5 James Slagle 2016-09-19 19:16:27 UTC
i see that the fix is landed in master upstream, but not in newton, so I proposed a backport:
https://review.openstack.org/#/c/372712/

we will want to pick that up downstream once it's merged upstream

Comment 6 James Slagle 2016-10-05 11:33:18 UTC
plan is to carry the patch in rdo and downstream packaging for now:
https://review.rdoproject.org/r/#/c/3044/

this is due to upstream not maintaining their stable branches

Comment 7 Jaromir Coufal 2016-10-10 02:33:33 UTC
James, I know this belongs to another DFG but since you are already on top of it,can you please finish it so it does not drop off the table? Thanks, jarda

Comment 8 Dmitry Tantsur 2016-10-13 12:30:15 UTC
James, is it fixed now? I didn't hit it in the latest puddle yesterday.

Comment 9 arkady kanevsky 2016-10-13 12:34:31 UTC
Where is a patch for OSP9 and OSP8?

Comment 10 Dmitry Tantsur 2016-10-13 12:44:36 UTC
Arkady, I wasn't aware this bug also affects OSP8 and 9. Is it the case for you?

Comment 11 arkady kanevsky 2016-10-13 13:16:26 UTC
We bumped into this when we upgraded from OSP8 to OSP9 (JS-5.0 -> JS-6.0)

Comment 12 Dmitry Tantsur 2016-10-17 14:46:14 UTC
I've run 'openstack undercloud install' several times with the latest puddle, and I've never seen this issue, so I assume it's fixed. Arkady, please file a separate bug for your upgrade issue, so that we can track releases simpler. Thanks!

Comment 13 arkady kanevsky 2016-10-17 14:59:39 UTC
Not a problem for JS-6.0.

Comment 14 Chris Dearborn 2016-10-17 15:11:29 UTC
We encountered this problem when installing the October 5th puddle of OSP 10.

Comment 15 Chris Dearborn 2016-10-17 15:12:23 UTC
To clarify: it is an issue with JS-7.0.

Comment 17 Chris Dearborn 2016-11-16 14:34:12 UTC
I verified that this is fixed in the 11/14 puddle.

Comment 19 errata-xmlrpc 2016-12-14 16:02:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.