Bug 137730 - Window List does not list windows on second head when using Twinview
Window List does not list windows on second head when using Twinview
Status: CLOSED DUPLICATE of bug 138874
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-31 12:50 EST by Ben Steeves
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Steeves 2004-10-31 12:50:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041016
Firefox/0.10.1

Description of problem:
When configured to "display windows from all workspaces", the Window
List applet does not display the names of windows on the 2nd head of a
system set up with Twinview.  If you drag the window from the 2nd head
to the 1st head, the window title appears when you drop the window.

For the purposes of this explanation, "1st" head refers to the head on
which the panel is placed.  The two heads are combined into one
spanning desktop (i.e., windows can stradle the border between the two
heads.  Interestingly enough, the window only shows up in the Window
list when the window is more than half on the 1st head.

Also interesting -- if you put a panel on the 2nd head, all windows --
regardless of head -- are listed!

After doing a "killall -HUP gnome-panel", the window lists are still
out of sync, but the 1st head has all windows listed, and the 2nd head
is missing windows on the 1st head. 

Version-Release number of selected component (if applicable):
gnome-panel-2.8.1-2

How reproducible:
Always

Steps to Reproduce:
1. Set up a dualhead display using Twinview
2. Put a panel on both heads, put a Window List applet on both heads
3. Set both panels to display windows from all workspaces.
4. Open windows on both heads, move them around a bit

    

Actual Results:  The panels get out of sync.

Expected Results:  The panels should always agree.

Additional info:
Comment 1 Andrew D. Stadler 2004-11-23 16:44:29 EST
I would like to claim that this should be raised to "high" severity,
meaning crash or data loss, based on the following scenario:

1.  Open a document in 2nd monitor (e.g. word processor)
2.  Enter lots and lots of important information
3.  Accidentally click the "minimize" icon.

Hey, where did my window go?  The window has been minimized but is not
visible anywhere.  The only way I've been able to find, to restore it,
is to use alt-tab.  But many users don't know about this feature.  To
them, this scenario is data loss.
Comment 2 Kevin R. Page 2004-12-21 21:49:29 EST
This looks like a dup of bug #138874
Comment 3 Mark McLoughlin 2005-01-05 05:40:14 EST

*** This bug has been marked as a duplicate of 138874 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:06:43 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.