Bug 137739 - vim-enhanved should require vim-common >= VERSION
vim-enhanved should require vim-common >= VERSION
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: vim (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-10-31 14:37 EST by Todd Warner
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-11-12 07:35:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Todd Warner 2004-10-31 14:37:19 EST
RHEL 3 AS U3...

Apparently vim-enhanced merely requires vim-common or any version.
I.e., it does not require the *same* version of vim-common. Hence, I
up2dated vim-enhanced and ended up with this combination of RPMs
installed on my box:


Which leads to vim-enhanced looking for config settings in a directory
that does not exist.

[root@test03 root]# vim /etc/sysconfig/rhn/up2date
Error detected while processing /etc/vimrc:
line   44:
E484: Can't open file /usr/share/vim/vim63/syntax/syntax.vim
Hit ENTER or type command to continue
[root@test03 root]# rpm -qf /usr/share/vim/vim63
error: file /usr/share/vim/vim63: No such file or directory
Comment 1 Todd Warner 2004-10-31 14:38:17 EST
s/vim-common or any version/vim-common of any version
Comment 3 Damian Menscher 2005-01-03 17:16:27 EST
I'm perplexed that you managed to report this bug on 10/31, given that
the U4 update containing the vim63 packages wasn't out until 12/21. 
More perplexing, however, is the fact that RedHat didn't fix it.

What does closed:nextrelease mean?  Didn't the U4 upgrade that came
out two months after this bug was closed count as the next release?
Comment 4 Karsten Hopp 2005-01-25 08:39:32 EST
first: check who reported the bug, maybe he got early access ?
then: vim-enhanced-6.3.029-1.30E.3.i386 was the version released with U4.
rpm -qp --requires vim-enhanced-6.3.029-1.30E.3.i386.rpm | grep common
vim-common = 1:6.3.029-1.30E.3

What are you complaining about? This looks ok to me...
Comment 5 Damian Menscher 2005-01-25 11:07:24 EST
The problem we had was similar:

Running RHEL3U3, we hadn't updated to U4 yet, but wanted to install
the vim-X11 package.  Ran up2date -i vim-X11.  That uses version 6.3,
and upgraded vim-common to 6.3.  But vim-minimal and vim-enhanced were
left at version 6.2, which meant a very badly broken setup.

Should I open this as a second bug?  I thought it fit under this one
(vim-enhanced allowed vim-common to be a different version than
itself, which it should not do), but seeing as you've closed this one....

Or maybe this has already been fixed in the 6.3 rpms?  I'm not sure
how to read the output of --requires, but the 6.3 vim-enhanced looks
right.  I'm guessing it was only the 6.2 vim-enhanced which was broken?
Comment 6 Karsten Hopp 2005-01-31 08:18:21 EST
The old packages didn't have an explicit requirement of
version/release and therefore rpm doesn't mind updating only some of
the vim subpackages. This can't happen anymore with the new packages.

Note You need to log in before you can comment on or make changes to this bug.