Bug 1377399 - RFE: Please add support for VBOX 5.1
RFE: Please add support for VBOX 5.1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vagrant (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vít Ondruch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-09-19 10:55 EDT by leigh scott
Modified: 2016-10-12 23:20 EDT (History)
12 users (show)

See Also:
Fixed In Version: vagrant-1.8.1-4.fc24 vagrant-1.8.1-2.fc23
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-09 02:21:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description leigh scott 2016-09-19 10:55:50 EDT
Issue forwarded from rpmfusion https://bugzilla.rpmfusion.org/show_bug.cgi?id=4263

Description of problem:

The update of VirtualBox 5.0 to 5.1 cause an
incomatibility issue with vagrant, that depends
on VirtualBox up to 5.0, but fails to run on 5.1.

There is a work-a-round for that problem, cause
my vagrant did not came up anymore. Go to 
the vagrant installation directory 

cd /usr/share/vagrant/plugins/providers/virtualbox/driver

and change the meta.rb in that way, that
VirtualBox 5.1 is mapped to 5.0.
Comment 1 Sergio Monteiro Basto 2016-09-19 12:02:34 EDT
I had to update VBox to 5.1 , to support kernel 4.7 (at least in guest additions)
https://bugzilla.rpmfusion.org/show_bug.cgi?id=4251#c0
Comment 2 Vít Ondruch 2016-09-20 08:37:31 EDT
Can somebody please test this scratch build?

http://koji.fedoraproject.org/koji/taskinfo?taskID=15716951

Thx.
Comment 3 Vít Ondruch 2016-09-20 08:41:52 EDT
BTW does this apply to F23 as well?
Comment 4 leigh scott 2016-09-20 09:21:56 EDT
(In reply to Vít Ondruch from comment #3)
> BTW does this apply to F23 as well?

Yes it does.
Comment 5 Vít Ondruch 2016-09-21 04:25:26 EDT
(In reply to leigh scott from comment #4)
> (In reply to Vít Ondruch from comment #3)
> > BTW does this apply to F23 as well?
> 
> Yes it does.

Thx for confirmation.

Now if somebody can test the patch ... I don't have the environment ...
Comment 6 Mike Goodwin 2016-09-21 21:36:36 EDT
Scratch build works for me. I'm vagrant to do local ansible testing.
Comment 7 Vít Ondruch 2016-09-27 07:01:47 EDT
(In reply to Mike Goodwin from comment #6)
> Scratch build works for me.

Thx for testing. I missed you comment. Building the official build.

(In reply to leigh scott from comment #4)
> (In reply to Vít Ondruch from comment #3)
> > BTW does this apply to F23 as well?
> 
> Yes it does.

Here is the F23 scratch build for testing:

http://koji.fedoraproject.org/koji/taskinfo?taskID=15825157
Comment 8 Fedora Update System 2016-09-28 01:57:48 EDT
vagrant-1.8.1-4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d783e0ef27
Comment 9 Pavel Valena 2016-10-03 14:49:28 EDT
(In reply to Vít Ondruch from comment #7)
> (In reply to Mike Goodwin from comment #6)
> > Scratch build works for me.
> 
> Thx for testing. I missed you comment. Building the official build.
> 
> (In reply to leigh scott from comment #4)
> > (In reply to Vít Ondruch from comment #3)
> > > BTW does this apply to F23 as well?
> > 
> > Yes it does.
> 
> Here is the F23 scratch build for testing:
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=15825157

Works fine with VirtualBox-5.1.6-1.fc23.x86_64 from rpmfusion.

Thanks.
Comment 10 Fedora Update System 2016-10-04 10:22:28 EDT
vagrant-1.8.1-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a6feb66def
Comment 11 Fedora Update System 2016-10-09 02:21:37 EDT
vagrant-1.8.1-4.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2016-10-12 22:50:57 EDT
vagrant-1.8.1-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Sergio Monteiro Basto 2016-10-12 23:20:58 EDT
Many thanks Vondruch !

Note You need to log in before you can comment on or make changes to this bug.