Bug 137745 - resume hangs after usb device disconnect during suspend
Summary: resume hangs after usb device disconnect during suspend
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-31 23:16 UTC by Jost Diederichs
Modified: 2015-01-04 22:11 UTC (History)
2 users (show)

Fixed In Version: kernel-2.6.12-1.1372_FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-24 00:33:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jost Diederichs 2004-10-31 23:16:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914
Firefox/0.10.1

Description of problem:
If I disconnect a usb device (like a bluetooth dongle) while the
laptop is in standby, resume will not complete: the last message
visible on the console is:
"usb 1-1: control timeout on ep0in"
If I then plug the bluetooth dongle back in, the resume process
recovers and everything behaves normal. 
I never had this problem on kernels <= 2.6.8 or 2.4 kernels.


Version-Release number of selected component (if applicable):
all 2.6.9 versions of fc3test kernels

How reproducible:
Sometimes

Steps to Reproduce:
1. suspend the laptop with a usb device connected (echo -n "mem" >
/sys/power/state)
2. disconnect the device while the laptop is in standby
3. bring the laptop out of standby
    

Additional info:

Comment 1 Jost Diederichs 2005-04-13 07:10:20 UTC
This bug appears fixed in 2.6.10 and later kernels

Comment 2 Dave Jones 2005-07-15 18:05:51 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.


Note You need to log in before you can comment on or make changes to this bug.