Bug 1377493 - Horizon Login Page Unnecessarily Has a Scrollbar on the Username and Password Div
Summary: Horizon Login Page Unnecessarily Has a Scrollbar on the Username and Password...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 10.0 (Newton)
Assignee: Radomir Dopieralski
QA Contact: Ido Ovadia
URL:
Whiteboard:
: 1382384 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-19 21:29 UTC by Dustin Schoenbrun
Modified: 2016-12-14 16:02 UTC (History)
5 users (show)

Fixed In Version: python-django-horizon-10.0.0-0.20161002185148.3252153.3.el7ost
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2016-12-14 16:02:48 UTC


Attachments (Terms of Use)
Scrollbar visible in Firefox (196.65 KB, image/png)
2016-09-19 21:29 UTC, Dustin Schoenbrun
no flags Details
Chrome inspector view with width of div set to a larger value (336.11 KB, image/png)
2016-09-19 23:32 UTC, Dustin Schoenbrun
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description Dustin Schoenbrun 2016-09-19 21:29:41 UTC
Created attachment 1202634 [details]
Scrollbar visible in Firefox

Description of problem:
When logging into the OpenStack Horizon UI, the area where the user would input the username and password unnecessarily has a scrollbar. 

Version-Release number of selected component (if applicable):
python-django-horizon-10.0.0-0.20160907182334.aff061d.1.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install an OpenStack instance using Packstack making sure to enable Horizon in the Packstack answers file.
2. Navigate to the Horizon URL 
3. Observe the scrollbar in the login input div

Actual results:
A scrollbar appears in the login input div on the login page.

Expected results:
No scrollbar should appear for the login div.

Additional info:
This was observed occurring in Google Chrome (53.0.2785.116 (64-bit)) and Firefox (48.0.1) running on Fedora 24.

It looks like if you change the width of the div, from it's default value of 176 to about 200px wide, the scrollbar will go away.

Comment 2 Dustin Schoenbrun 2016-09-19 23:32:21 UTC
Created attachment 1202641 [details]
Chrome inspector view with width of div set to a larger value

Added screenshot of a possible fix using the Chrome inspector view. It looks like changing the width of the div where the login credentials are entered makes the scrollbar go away.

Comment 3 Radomir Dopieralski 2016-09-30 13:38:57 UTC
I can't reproduce this problem on my (Linux) machine, neither in Firefox, Chromium or Chrome. I suspect it has something to do with the fonts available on the system that runs the browser. I will try to make the styles more robust, instead of using hardcoded widths.

Comment 4 Radomir Dopieralski 2016-10-06 14:35:55 UTC
*** Bug 1382384 has been marked as a duplicate of this bug. ***

Comment 6 Ido Ovadia 2016-10-25 15:16:37 UTC
Verified
========
python-django-horizon-10.0.0-3.el7ost.noarch

Comment 9 errata-xmlrpc 2016-12-14 16:02:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.