Bug 1377616 - When the 'Select Live ISO' button is pressed the mediawriter segfaults
Summary: When the 'Select Live ISO' button is pressed the mediawriter segfaults
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mediawriter
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Bříza
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: WaylandRelated F25FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2016-09-20 08:33 UTC by Petr Schindler
Modified: 2016-09-27 00:31 UTC (History)
4 users (show)

Fixed In Version: mediawriter-3.97.1-0.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 00:31:05 UTC


Attachments (Terms of Use)
backtrace from gdb (7.56 KB, text/plain)
2016-09-20 10:51 UTC, Kamil Páral
no flags Details

Description Petr Schindler 2016-09-20 08:33:54 UTC
Description of problem:
When I click on the 'Select Live ISO' button in Custom OS submenu the application falls.

Terminal output:
$ mediawriter 

(mediawriter:25558): Gdk-WARNING **: gdkwindow-x11.c:5554 drawable is not a native X11 window

(mediawriter:25558): GLib-GObject-WARNING **: invalid cast from 'GdkWaylandDisplay' to 'GdkX11Display'
Segmentation fault (core dumped)

Version-Release number of selected component (if applicable):
mediawriter-3.96.0-0.fc25.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run 'Fedora Media Writer' from overview or mediawriter from terminal
2. Select 'Custom OS'
3. Click on Select Live ISO button

Actual results:
Application falls

Expected results:
File selector window should appear

Additional info:

Comment 1 Martin Bříza 2016-09-20 09:35:28 UTC
Please try installing the qt5-qtbase-gui package and tell me if that helped.

Comment 2 Petr Schindler 2016-09-20 09:41:19 UTC
Package qt5-qtbase-gui-5.7.0-3.fc25.x86_64 is already installed. So that didn't help.

Comment 3 Kamil Páral 2016-09-20 10:45:36 UTC
The same problem here. I have the crash captured by abrt, not neither FAF nor local debugging works ("the report is unusable").

Comment 4 Petr Schindler 2016-09-20 10:46:27 UTC
(gdb) run
Starting program: /usr/bin/mediawriter 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
[New Thread 0x7fffe7f16700 (LWP 3349)]
[New Thread 0x7fffdfdb6700 (LWP 3350)]
[New Thread 0x7fffdf5b5700 (LWP 3351)]
[New Thread 0x7fffdedb4700 (LWP 3352)]
[New Thread 0x7fffde493700 (LWP 3353)]
[New Thread 0x7fffdd5ff700 (LWP 3355)]
[New Thread 0x7fffc63e2700 (LWP 3357)]
[New Thread 0x7fffc5be1700 (LWP 3358)]
[New Thread 0x7fffc53cf700 (LWP 3359)]

(mediawriter:3345): Gdk-WARNING **: gdkwindow-x11.c:5554 drawable is not a native X11 window

(mediawriter:3345): GLib-GObject-WARNING **: invalid cast from 'GdkWaylandDisplay' to 'GdkX11Display'

Thread 1 "mediawriter" received signal SIGSEGV, Segmentation fault.
0x00007fffefa40328 in XChangeProperty (dpy=0x5555558778a0, w=w@entry=0, property=property@entry=68, type=type@entry=33, format=format@entry=32, mode=mode@entry=0, data=0x7fffffff5e48 "\r", nelements=1)
    at ChProp.c:46
46	    LockDisplay(dpy);

Comment 5 Kamil Páral 2016-09-20 10:47:56 UTC
Proposing as a blocker:
"Release-blocking live and dedicated installer images must boot when written to optical media of an appropriate size (if applicable) and when written to a USB stick with any of the officially supported methods."
https://fedoraproject.org/wiki/Fedora_25_Beta_Release_Criteria#Release-blocking_images_must_boot

Comment 6 Kamil Páral 2016-09-20 10:51:43 UTC
Created attachment 1202847 [details]
backtrace from gdb

Comment 7 Martin Bříza 2016-09-21 08:54:19 UTC
Please try installing qt5-qtx11extras and tell me if that helped.
This bug doesn't happen to me so I assume it's some dependency...

Comment 8 Kamil Páral 2016-09-21 14:36:35 UTC
I do have it installed already:
qt5-qtx11extras-5.7.0-2.fc25.x86_64

But I just tried this with fully updated F25 VM (running Wayland), and the crash doesn't occur - a file dialog pops up just fine. I'll try to investigate more.

Comment 9 Kamil Páral 2016-09-22 12:05:04 UTC
So, my first finding is that the crash does not occur if I run it like this:
$ GDK_BACKEND=x11 mediawriter
This could be a temporary fix until we can figure out the cause of the crash.

Second finding is that if I run mediawriter with x11 backend on my bare metal machine, I get a gtk file chooser dialog. If I run mediawriter in my VM (with any backend), I get QT-style file chooser dialog (and no crash). I would suspect this is somehow related. I see no crash in a VM and non-native dialogs. Maybe opening the native dialogs causes the crash?

How can I debug why I see native dialogs on some systems and non-native dialogs on others?

Comment 10 Martin Bříza 2016-09-22 12:07:53 UTC
That's what I was suspecting: I think opening a native GTK dialog on Wayland means you're opening a native Wayland dialog from a X11 client (that tries to set some X11 features of it). 
However, on my machine with f25 I get a native GTK dialog both in Wayland and X GNOME session without crashing.

Comment 11 Kamil Páral 2016-09-22 12:30:34 UTC
I found the difference. If I have qgnomeplatform-0.2-9.20160718git.fc25 installed, mediawriter doesn't crash, but file dialogs are QT-style (which doesn't make much sense to me, qgnomeplatform should *improve* integration). If qgnomeplatform is not installed, mediawriter crashes, or shows GTK-style dialogs with x11 backend.

Comment 12 Kamil Páral 2016-09-22 12:33:01 UTC
One further note, qgnomeplatform is installed by default for fresh F25 installations, but it seems it is not present on upgraded machines (neither mine nor pschindl's machine had it installed).

Comment 13 Martin Bříza 2016-09-22 12:39:25 UTC
Thanks for the extensive research, I worked around this upstream with the GDK_BACKEND variable before we have a proper fix in qgnomeplatform.

Comment 14 Fedora Update System 2016-09-23 05:23:54 UTC
mediawriter-3.97.0-0.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d84f684d42

Comment 15 Kamil Páral 2016-09-23 12:12:01 UTC
(In reply to Fedora Update System from comment #14)
> mediawriter-3.97.0-0.fc25 has been pushed to the Fedora 25 testing

This is now fixed with or without qgnomeplatform installed.

Comment 16 Fedora Update System 2016-09-24 17:51:43 UTC
mediawriter-3.97.1-0.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e34fd77aaf

Comment 17 Geoffrey Marr 2016-09-26 23:38:47 UTC
Discussed during the 2016-09-26 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker was made as this bug violates the following criteria: "Release-blocking live and dedicated installer images must boot when written to optical media of an appropriate size (if applicable) and when written to a USB stick with any of the officially supported methods", (as Fedora Media Writer is an 'officially supported method').

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2016-09-26/f25-blocker-review.2016-09-26-16.04.txt

Comment 18 Fedora Update System 2016-09-27 00:31:05 UTC
mediawriter-3.97.1-0.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.