Bug 1377725 - Applicable erratas are not shown for content hosts
Summary: Applicable erratas are not shown for content hosts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Errata Management
Version: 6.2.0
Hardware: All
OS: All
medium
medium vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Peter Ondrejka
URL:
Whiteboard:
Depends On:
Blocks: 1435022 1426425
TreeView+ depends on / blocked
 
Reported: 2016-09-20 13:09 UTC by Anand Agrawal
Modified: 2020-07-16 08:54 UTC (History)
8 users (show)

Fixed In Version: tfm-rubygem-katello-3.0.0.115-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1426425 (view as bug list)
Environment:
Last Closed: 2017-05-01 13:54:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 16762 0 Normal Closed Content -> Errata: showing incorrect hosts for installable errata 2020-04-27 09:05:06 UTC
Red Hat Product Errata RHBA-2017:1191 0 normal SHIPPED_LIVE Satellite 6.2.9 Async Bug Release 2017-05-01 17:49:42 UTC

Description Anand Agrawal 2016-09-20 13:09:58 UTC
Description of problem:

When selecting a specific errata and view what hosts it's applicable to, it shows a list. When checking "Only show content hosts where the errata is currently installable in the host's Lifecycle Environment", it shows much larger list, almost all hosts. This isn't right

Installable always means applicable also. Applicable might not be installable (if not published). Errata can't be installable if it's not applicable.

So, errata which is installable for host is also applicable for host. So, applicable list should be larger than installable

Version-Release number of selected component (if applicable):

6.2

How reproducible:
Always

Steps to Reproduce:
1. Go to Content > Errata
2. Select one or more errata
3. Click apply
4. A list of host will be listed
5. Click on the checkbox "Only show content hosts where the errata is currently installable in the host's Lifecycle Environment"

6. New list will be populated with more hosts

Actual results:

I can see some host, which have installable errata but those hosts do not show up for applicable.

Expected results:

The list of the applicable host should be greater than the list of installable host, because Installable always means applicable also.

Comment 7 Brad Buckingham 2016-09-30 18:26:17 UTC
Created redmine issue http://projects.theforeman.org/issues/16762 from this bug

Comment 8 Brad Buckingham 2016-10-03 17:43:02 UTC
Upstream Katello PR: https://github.com/Katello/katello/pull/6369

Comment 10 Peter Ondrejka 2016-11-01 10:37:44 UTC
Verified in Sat 6.3 snap 5, installable content hosts are now listed correctly in the errata view.

Comment 13 Satellite Program 2017-02-23 21:12:07 UTC
Please add verifications steps for this bug to help QE verify

Comment 15 Brad Buckingham 2017-03-08 16:33:15 UTC
The following scenario allowed for recreation of the issue (prior to the fix):

Scenario (from UI)

- have multiple content hosts that have installable errata; however, have different errata for some of the hosts... e.g. host 1 has errata A & B, host 2 has errata A & B, host 3 has errata C

- go to Content > Errata
select errata id for A
- click 'Content Hosts'
- observe that hosts 1 & 2 are listed
- click checkbox next to 'Only show content hosts where the errata is currently installable in the host's Lifecycle Environment.'

Result:
- all 3 hosts are shown; however, host 3 does not need errata A

Comment 16 Peter Ondrejka 2017-03-27 12:13:15 UTC
Verified in Satellite 6.2.9-1 using steps from comment #15. Installable hosts for an erratum are now listed correctly

Comment 18 errata-xmlrpc 2017-05-01 13:54:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1191


Note You need to log in before you can comment on or make changes to this bug.