Bug 1377741 - maximized video is shifted in totem after gtk3 update
Summary: maximized video is shifted in totem after gtk3 update
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk3
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker AcceptedFreezeException
Keywords:
Depends On:
Blocks: WaylandRelated F25BetaFreezeException F25FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2016-09-20 13:56 UTC by Kamil Páral
Modified: 2016-10-05 22:26 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-10-05 22:26:52 UTC


Attachments (Terms of Use)
bug demonstration video (2.77 MB, application/octet-stream)
2016-09-20 13:56 UTC, Kamil Páral
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 771915 None None None 2016-09-27 07:49 UTC

Description Kamil Páral 2016-09-20 13:56:51 UTC
Created attachment 1202901 [details]
bug demonstration video

Description of problem:
After gtk3 update, you can no longer watch maximized or fullscreen videos in totem. If you maximize/fullscreen the window, the video gets shifted (in my case, moved to the bottom right). If I unmaximize the window, the video is still shifted and does not reflect the current window borders.

See the video.

I narrowed down the regression to gtk3. It works fine with:
gtk3-3.21.5-1.fc25.x86_64
but breaks with:
gtk3-3.21.6-2.fc25.x86_64

I'm using a wayland session.

Version-Release number of selected component (if applicable):
gnome-session-wayland-session-3.21.90-1.fc25.x86_64
gnome-shell-3.21.92-1.fc25.x86_64
gtk3-3.21.6-1.fc25.x86_64
libwayland-client-1.11.94-1.fc25.x86_64
libwayland-cursor-1.11.94-1.fc25.x86_64
libwayland-server-1.11.94-1.fc25.x86_64
mesa-libwayland-egl-12.0.2-1.fc25.x86_64
mutter-3.21.92-1.fc25.x86_64
xorg-x11-server-Xwayland-1.18.4-5.fc25.x86_64

How reproducible:
always

Steps to Reproduce:
1. run a video in totem
2. either maximize it or fullscreen it
3. see the video shifted
4. unmaximize the window
5. see the video not respect window borders

Comment 1 Kamil Páral 2016-09-20 14:00:54 UTC
So, I further narrowed it down. It works with:
gtk3-3.21.6-1.fc25.x86_64
and is broken with:
gtk3-3.21.6-2.fc25.x86_64

Comment 2 Kamil Páral 2016-09-20 14:02:18 UTC
Proposing as a blocker:
"All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test. "
https://fedoraproject.org/wiki/Fedora_25_Final_Release_Criteria#Default_application_functionality

Watching movies in full screen might be considered a default movie player functionality by some. Please note that the affected gtk3 update is still just in updates-testing atm.

Comment 3 Kalev Lember 2016-09-20 14:34:19 UTC
Sounds like a regression from "gtkwindow: Update shadow size on state change", https://git.gnome.org/browse/gtk+/commit/?id=4cb1b9645e84054c059f174240e8e288c4befe05

Comment 4 Olivier Fourdan 2016-09-23 11:00:18 UTC
Could be related to that change, yes, but the change still looks correct to me, I wonder how that affects clutter-gtk though.

Comment 5 Olivier Fourdan 2016-09-23 13:52:13 UTC
It appears that the problem doesn't lie in clutter-gtk at all, this is purely gdk related apparently, the problem is that the impl abs_x,abs_y being out of sync after the patch Kalev mentioned in comment 3, not sure why yet though...

Comment 6 Kamil Páral 2016-09-26 17:16:23 UTC
The problem does not occur if I run totem with GDK_BACKEND=x11.

Comment 7 Geoffrey Marr 2016-09-26 23:36:07 UTC
Discussed during the 2016-09-26 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker was made as watching a full-screen video is considered to be "basic functionality" of totem and so violates the following Final criteria: "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test"

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2016-09-26/f25-blocker-review.2016-09-26-16.04.txt

Comment 8 Olivier Fourdan 2016-09-28 08:39:57 UTC
The fix for this has been pushed upstream in gtk+ master.

Comment 9 Kalev Lember 2016-09-28 08:44:47 UTC
I've backported the fix to gtk3-3.22.0-2.fc25.

Proposing as a freeze exception for the beta release. This has already been accepted as a blocker for the final release and as such should qualify for a FE for beta.

Comment 10 Matthias Clasen 2016-09-28 09:52:29 UTC
Thanks, Kalev

Comment 11 Fedora Update System 2016-09-28 20:52:37 UTC
gtk3-3.22.0-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2787de39a2

Comment 12 Adam Williamson 2016-09-29 15:47:10 UTC
Sure, FE for Beta makes sense.

Comment 13 Adam Williamson 2016-09-29 15:47:31 UTC
whoops, I meant that to be a *vote*, not an accepted :)

Comment 14 Dennis Gilmore 2016-09-30 17:21:31 UTC
+1 FE, though it can be handled just as well via updates

Comment 15 Ben Williams 2016-09-30 17:22:10 UTC
+1 beta blocker and +1 FE

Comment 16 Stephen Gallagher 2016-09-30 17:24:33 UTC
It's not a beta blocker; it doesn't violate any Beta criteria.

I'm +1 FE on this only because this is functionality someone could reasonably be expected to try out in a Live image. Normally I'd recommend avoiding changing gtk3 during a Freeze.

Comment 17 Adam Williamson 2016-09-30 18:10:17 UTC
that's +4 FE, marking accepted.

Comment 18 Kamil Páral 2016-10-04 12:30:37 UTC
Verified fixed with gtk3-3.22.0-2.fc25.

Comment 19 Fedora Update System 2016-10-05 22:26:52 UTC
gtk3-3.22.0-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.