Due to a recent update on Javascript code a full page refresh on your browser might be needed.
Bug 1377825 - macOS, hang on launch
Summary: macOS, hang on launch
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mediawriter
Version: 25
Hardware: Unspecified
OS: Mac OS
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Bříza
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1310542
TreeView+ depends on / blocked
 
Reported: 2016-09-20 17:35 UTC by Chris Murphy
Modified: 2016-11-15 13:33 UTC (History)
5 users (show)

Fixed In Version: mediawriter-3.97.1-0.fc25 mediawriter-4.0.4-0.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-15 13:33:32 UTC
Type: Bug


Attachments (Terms of Use)
problem report (764.56 KB, text/plain)
2016-09-20 17:36 UTC, Chris Murphy
no flags Details
problem report 3.97.1-17-g480c143.dmg (801.09 KB, text/plain)
2016-10-10 22:15 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2016-09-20 17:35:42 UTC
Description of problem:

Hang on launch 115% CPU, after a minute I get a Problem Report for mediawriter dialog contents attached).

Version-Release number of selected component (if applicable):
mediawriter 3.96.1
macOS 10.11.6

How reproducible:
Always


Steps to Reproduce:
1. Download FedoraMediaWriter-mac-3.96.1.dmg https://github.com/MartinBriza/MediaWriter/releases/ 
2. Copy to /Applications
3. Launch (and provide security exception due to lack of signing)

Actual results:
Hang

Expected results:
Shouldn't hang. This is a regression, the previous one I tried from dgilmore a few weeks ago did launch.

Additional info:

Comment 1 Chris Murphy 2016-09-20 17:36:37 UTC
Created attachment 1202985 [details]
problem report

Comment 2 Martin Bříza 2016-09-21 12:21:55 UTC
When you start the application directly from the .dmg, does it work, please? You can bypass the security daemon by "right" (two finger) click and then Open.

Comment 3 Chris Murphy 2016-09-21 17:41:02 UTC
(In reply to Martin Bříza from comment #2)
> When you start the application directly from the .dmg, does it work, please?

No it still hangs indefinitely and I have to force quit.


> You can bypass the security daemon by "right" (two finger) click and then
> Open.

Nope, it still comes up.

Comment 4 Fedora Update System 2016-09-24 17:52:33 UTC
mediawriter-3.97.1-0.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e34fd77aaf

Comment 5 Chris Murphy 2016-09-26 14:42:35 UTC
No change with FedoraMediaWriter-mac-3.97.1.dmg. It hangs whether launched from the DMG or copied to /Applications.

Comment 6 satellitgo 2016-09-26 15:20:33 UTC
FedoraMediaWriter-mac-3.97.1.dmg  works fine here:
OS 10.11.2
MacBookPro 8.1  (i7)
very slow downloads but writes booting USB's for me
Installed from one on booted USB (right efi icon ) wrote to external USB Hd and it booted.

Comment 7 Chris Murphy 2016-09-26 15:32:51 UTC
For me:
OS 10.11.6
MacBookPro 8.2  (i7)

There's no useful information either, I have to force quit and then I get the hang problem report that the OS generates (which is attached).

Comment 8 Fedora Update System 2016-09-27 00:32:16 UTC
mediawriter-3.97.1-0.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Chris Murphy 2016-09-27 00:58:55 UTC
Nope, I still have this problem, it's not fixed.

Comment 10 ajs 2016-09-28 17:56:07 UTC
FedoraMediaWriter-mac-3.97.1.dmg
macOS 10.12 (also observed using OS X 10.11.6)

I see the same problem.  There is really not much feedback from media writer as to what it is doing.  I tried launching from the command line with the '--testing' argument but still there was no feedback.

When I look at the diagnostic messages in the system console, I see that every few seconds media writer is triggering something with wifi.

E.g.

    com.apple.message.domain: com.apple.wifi.internal.scanning
    com.apple.message.error: No Error
    com.apple.message.duration: 3
    com.apple.message.process_name: mediawriter
    com.apple.message.mac_address: xx:xx:xx:xx:xx:xx
    SenderMachUUID: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

I can't find any other information.

Is there a way to turn on debugging?

Comment 11 Martin Bříza 2016-09-29 14:53:49 UTC
From trying to google your log message, it seems that's something related to the Qt network manager: https://groups.google.com/forum/#!topic/golden-cheetah-users/fsMM-LvvFQc . It's most likely benign and related to checking if network connectivity is still available.

There is no real debug code in FMW as of now unfortunately, just a few informational messages and warnings and errors if something goes wrong. I'll add a few debug messages to the next release so we see if it's running in the background.

Honestly, I don't know how to test this. For me and a few friends I asked to test the tool it worked okay. One more strange element to the whole puzzle is ausil's builds works for you. It doesn't work for me...

Comment 12 Adam Williamson 2016-09-30 22:27:48 UTC
mbriza: both cmurf and ajs seem to be on quite new versions (10.11.6 and 10.12), while satellit is on something older (10.11.2). What version did you test with?

Comment 13 Martin Bříza 2016-10-03 11:10:31 UTC
I'm on 10.11.6 too. As I mentioned on IRC, I think the most important builds are the ones done by dgilmore/ausil on his fedorapeople space. 
In Comment 11, I mentioned his build didn't work for me but they actually do.

Those are the ones that will get shipped in the end. Hopefully he'll do a new build soon so we see if nothing changed over the time and they still work.

Comment 14 Adam Williamson 2016-10-03 15:51:22 UTC
Ah - well right now I have the wiki page linking to the github releases page for MacOS, should we change it to point at Dennis' builds? And if so can you give me the correct URL for that?

Comment 15 Chris Murphy 2016-10-10 22:15:56 UTC
Created attachment 1208967 [details]
problem report 3.97.1-17-g480c143.dmg

Comment 16 Chris Murphy 2016-10-11 00:28:13 UTC
OK good news. I created a new user account, logged in, and mediawriter launches; I can also quit and still relaunch; and log out and launch again. The problem doesn't happen with the new user.

This means there's some statefulness in the current user that's causing the problem. It may have to do with prior mediawriter's saving some state that something doesn't like.

near:~ chris$ find ~/ -name "*mediawriter*"
/Users/chris//Library/Application Support/com.apple.sharedfilelist/com.apple.LSSharedFileList.ApplicationRecentDocuments/com.yourcompany.mediawriter.sfl
/Users/chris//Library/Application Support/CrashReporter/mediawriter_A9D64CE6-71F9-5004-813E-60DED8EB4925.plist
/Users/chris//Library/Preferences/com.yourcompany.mediawriter.mediawriter.plist
/Users/chris//Library/Saved Application State/com.yourcompany.mediawriter.savedState

Deleting these one at a time, the problem still happens even once all are removed. So I'm not sure what statefulness is responsible for this.

Comment 17 Martin Bříza 2016-10-11 09:17:50 UTC
Thank you for the good news! I assume it's caused by something unrelated to the stored state of the mediawriter. I have tried downloading and running every version of mediawriter I have released and I have not experienced any freezes or crashes similar to yours. Could probably be caused by some other setting of your system...

Comment 18 Martin Bříza 2016-10-11 09:18:43 UTC
Adam, now you can provide this URL: https://ausil.fedorapeople.org/FedoraMediaWriter-osx-3.97.1-17-g480c143.dmg

Comment 19 Adam Williamson 2016-10-11 18:15:34 UTC
mbriza: can't we have a permanent download page? it's rather awkward having to update every time you make a release...

Comment 20 Martin Bříza 2016-10-12 08:15:37 UTC
Well you can still of course use the github page, except we won't be testing the real official builds done by our release engineering.
This would be until dgilmore and the rest of releng sort out a way to deliver the downloads.

Comment 21 Adam Williamson 2016-10-31 19:06:32 UTC
Dennis, is it possible to get some kind of un-changing link to the latest 'official' macOS and Windows(?) builds of mediawriter to use on https://fedoraproject.org/wiki/How_to_create_and_use_Live_USB ? Right now, as mentioned above, I'm just linking to the github releases page...

Comment 22 Dennis Gilmore 2016-11-01 03:27:30 UTC
(In reply to Adam Williamson from comment #21)
> Dennis, is it possible to get some kind of un-changing link to the latest
> 'official' macOS and Windows(?) builds of mediawriter to use on
> https://fedoraproject.org/wiki/How_to_create_and_use_Live_USB ? Right now,
> as mentioned above, I'm just linking to the github releases page...

the official builds are linked by websites, you would have toa sk them, afaik there is one already

Comment 23 Fedora Update System 2016-11-11 08:08:36 UTC
mediawriter-4.0.4-0.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-239cdfbfd6

Comment 24 Fedora Update System 2016-11-11 16:57:04 UTC
mediawriter-4.0.4-0.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-239cdfbfd6

Comment 25 Fedora Update System 2016-11-15 13:33:32 UTC
mediawriter-4.0.4-0.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.