Bug 137801 - kernel 1.649smp panics for scsi systems
kernel 1.649smp panics for scsi systems
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-01 10:10 EST by Sammy
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-02 09:51:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
initrd.out file (1.18 KB, text/plain)
2004-11-01 16:00 EST, Sammy
no flags Details
modprobe.conf file (1.22 KB, text/plain)
2004-11-01 16:02 EST, Sammy
no flags Details
initrd image (294.85 KB, application/octet-stream)
2004-11-01 16:23 EST, Sammy
no flags Details

  None (edit)
Description Sammy 2004-11-01 10:10:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux; X11; en_US) (KHTML, like Gecko)

Description of problem:
I installed 1.649 and rebooted and kernel could not mount scsi disk
and consequently could not find modules directory and kept looking for them under /lib/modxxx.ko etc.

In the config file there is only one difference: in 649:

CONFIG_SCSI_INITIO=m

whereas in 1.643 this does not exist. Does one have to add a module
to modprobe.conf? how? If this is the case mkinitrd is not recognizing it.

Version-Release number of selected component (if applicable):
kernel-2.6.9smp-1.649

How reproducible:
Always

Steps to Reproduce:
1. Install 1.649spm onto a scsi boot disk system
2. reboot
3.
    

Additional info:
Comment 1 Dave Jones 2004-11-01 15:02:52 EST
are you running a current mkinitrd ? It sounds like the initrd wasn't
created properly at install time.

The SCSI_INITIO change shouldnt affect you unless you actually have one of those
controllers.  This looks more like an mkinitrd bug to me.
Comment 2 Sammy 2004-11-01 15:17:26 EST
I am running mkinitrd-4.1.18-2, latest in devel. I did even recreate the initrd 
with the same result. I agree abouit mkinitrd. Please reassign. 
Comment 3 Jeremy Katz 2004-11-01 15:23:23 EST
What version of gawk do you have installed?
Comment 4 Sammy 2004-11-01 15:49:41 EST
gawk-3.1.3-9 
Comment 5 Jeremy Katz 2004-11-01 15:51:36 EST
Can you provide the output of /sbin/mkinitrd -v -f /tmp/initrd.out
$(uname -r) and cat /proc/modprobe.conf
Comment 6 Sammy 2004-11-01 16:00:22 EST
Created attachment 106046 [details]
initrd.out file
Comment 7 Sammy 2004-11-01 16:02:43 EST
Created attachment 106047 [details]
modprobe.conf file
Comment 8 Sammy 2004-11-01 16:05:26 EST
I can't do uname -r with 1.649 since I can't boot into it. What I have not shows: 
   2.6.9-1.643smp 
 
Comment 9 Jeremy Katz 2004-11-01 16:09:43 EST
I need the output of the mkinitrd command, not the actual file... 
Oops, sorry about the lack of clarity there
Comment 10 Sammy 2004-11-01 16:23:14 EST
Created attachment 106048 [details]
initrd image
Comment 11 Jeremy Katz 2004-11-01 16:34:03 EST
This looks sane... exactly what error messages do you get on
rebooting?  And can you remove quiet from your boot params to get the
more verbose output?
Comment 12 Sammy 2004-11-01 16:43:16 EST
I do not have quite as boot param...like to see what is happenning. 
 
Well, things start loading fine until we get to loading the modules. It 
tries to load the mptbase and sais it cannot find it in: 
 
./lib/kernel/drivers/message/fusion/ 
 
i.e. 2.6.9-1.643smp is missing from all module paths! 
 
Also, the size of the image is smaller than 1.643: 
 
-rw-r--r--  1 root root 515409 Oct 26 10:03 initrd-2.6.9-1.643smp.img 
-rw-r--r--  1 root root 301922 Nov  1 14:59 initrd-2.6.9-1.649smp.img 
 
 
Comment 13 Sammy 2004-11-01 19:42:14 EST
I did it again and actually none of the path shows up i.e. /xxxx.ko is not 
found etc. Do you have some older version (>15) that I can try to see? 
Comment 14 Jeremy Katz 2004-11-02 09:38:33 EST
Do you have /usr/bin/install installed?  What package is it from?  If
not, what version of coreutils do you have installed?
Comment 15 Sammy 2004-11-02 09:51:11 EST
You got me! It was not install but "strip". I had problems building another 
rpm with strip and assigned it to true instead and forgot to change it back. 
 
I am very very sorry. 

Note You need to log in before you can comment on or make changes to this bug.