Bug 1378071 - python-sphinx-1.5.1 is available
Summary: python-sphinx-1.5.1 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-sphinx
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michel Alexandre Salim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-21 12:38 UTC by Upstream Release Monitoring
Modified: 2017-02-27 22:52 UTC (History)
7 users (show)

Fixed In Version: python-sphinx-1.5.2-2.fc25
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-27 22:52:54 UTC
Type: ---


Attachments (Terms of Use)

Description Upstream Release Monitoring 2016-09-21 12:38:47 UTC
Latest upstream release: 1.5a1
Current version/release in rawhide: 1.1.3-9.el7
URL: http://sphinx-doc.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/4031/

Comment 1 Upstream Release Monitoring 2016-09-21 12:39:21 UTC
Rebase helper failed.
See logs and attachments in this bugzilla 'NoneType' object has no attribute 'get_rebasehelper_data'

Comment 2 Upstream Release Monitoring 2016-09-21 12:39:56 UTC
Failed to kick off scratch build.

cmd:  rpmbuild -bs /var/tmp/thn-GtoeD2/python-sphinx.spec
return code:  1
stdout:

stderr:
error: line 148: Unknown tag: Recommends:    graphviz

Comment 3 Upstream Release Monitoring 2016-10-18 00:25:00 UTC
Latest upstream release: 1.5a2
Current version/release in rawhide: 1.1.3-9.el7
URL: http://sphinx-doc.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/4031/

Comment 4 Upstream Release Monitoring 2016-10-18 00:25:34 UTC
Rebase helper failed.
See logs and attachments in this bugzilla 'NoneType' object has no attribute 'get_rebasehelper_data'

Comment 5 Upstream Release Monitoring 2016-10-18 00:26:11 UTC
Failed to kick off scratch build.

cmd:  rpmbuild -bs /var/tmp/thn-GsGsTp/python-sphinx.spec
return code:  1
stdout:

stderr:
error: line 148: Unknown tag: Recommends:    graphviz

Comment 6 Upstream Release Monitoring 2016-11-08 05:34:22 UTC
Latest upstream release: 1.5b1
Current version/release in rawhide: 1.1.3-11.el7
URL: http://sphinx-doc.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/4031/

Comment 7 Upstream Release Monitoring 2016-11-08 05:34:58 UTC
Rebase helper failed.
See logs and attachments in this bugzilla 'NoneType' object has no attribute 'get_rebasehelper_data'

Comment 8 Upstream Release Monitoring 2016-11-08 05:35:35 UTC
Failed to kick off scratch build.

cmd:  rpmbuild -bs /var/tmp/thn-JhY4Ro/python-sphinx.spec
return code:  1
stdout:

stderr:
error: line 149: Unknown tag: Recommends:    graphviz

Comment 9 Upstream Release Monitoring 2016-12-05 12:18:31 UTC
Latest upstream release: 1.5
Current version/release in rawhide: 1.1.3-11.el7
URL: http://sphinx-doc.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/4031/

Comment 10 Upstream Release Monitoring 2016-12-05 12:19:05 UTC
Rebase helper failed.
See logs and attachments in this bugzilla 'NoneType' object has no attribute 'get_rebasehelper_data'

Comment 11 Upstream Release Monitoring 2016-12-05 12:19:41 UTC
Failed to kick off scratch build.

cmd:  rpmbuild -bs /var/tmp/thn-Jl46Vp/python-sphinx.spec
return code:  1
stdout:

stderr:
error: line 149: Unknown tag: Recommends:    graphviz

Comment 12 Upstream Release Monitoring 2016-12-14 00:21:26 UTC
Latest upstream release: 1.5.1
Current version/release in rawhide: 1.1.3-11.el7
URL: http://sphinx-doc.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/4031/

Comment 13 Upstream Release Monitoring 2016-12-14 00:22:01 UTC
Rebase helper failed.
See logs and attachments in this bugzilla 'NoneType' object has no attribute 'get_rebasehelper_data'

Comment 14 Upstream Release Monitoring 2016-12-14 00:22:37 UTC
Failed to kick off scratch build.

cmd:  rpmbuild -bs /var/tmp/thn-1y7Ttc/python-sphinx.spec
return code:  1
stdout:

stderr:
error: line 149: Unknown tag: Recommends:    graphviz

Comment 15 Rich Mattes 2016-12-28 19:33:05 UTC
It looks like sphinx 1.5.1 fixes an issue I'm seeing when building the documentation for pcl:

https://github.com/sphinx-doc/sphinx/issues/3212

I'm seeing the same assertion error in the above bug when building pcl in rawhide:

https://koji.fedoraproject.org/koji/taskinfo?taskID=17095758

python-docutils was updated to 0.13.1 in rawhide this morning, which looks like it's the root cause of the upstream issue.

Comment 16 Jerry James 2016-12-30 21:00:06 UTC
This appears to be the s(In reply to Rich Mattes from comment #15)
> It looks like sphinx 1.5.1 fixes an issue I'm seeing when building the
> documentation for pcl:

Ditto for sympy, which is failing to build due to the same issue.

Comment 17 Orion Poplawski 2016-12-31 03:26:50 UTC
I tried to update to 1.5.1: https://koji.fedoraproject.org/koji/taskinfo?taskID=17121977

======================================================================
ERROR: test_build_latex.test_latex('pdflatex', 'howto')
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/nose/case.py", line 197, in runTest
    self.test(*self.arg)
TypeError: deco() takes exactly 1 argument (2 given)

FAIL: test_build_linkcheck.test_anchors_ignored
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/nose/case.py", line 197, in runTest
    self.test(*self.arg)
  File "/builddir/build/BUILD/Sphinx-1.5.1/tests/util.py", line 271, in deco
    func(app, status, warning, *args2, **kwargs2)
  File "/builddir/build/BUILD/Sphinx-1.5.1/tests/test_build_linkcheck.py", line 38, in test_anchors_ignored
    assert not content
AssertionError: 
    # expect all ok when excluding #top
>>  assert not <output.txt contents>
    
-------------------- >> begin captured logging << --------------------
requests.packages.urllib3.connectionpool: DEBUG: Starting new HTTP connection (1): example.com
requests.packages.urllib3.connectionpool: DEBUG: Starting new HTTPS connection (1): www.w3.org
requests.packages.urllib3.connectionpool: DEBUG: Starting new HTTP connection (1): example.com
requests.packages.urllib3.connectionpool: DEBUG: Starting new HTTP connection (1): example.com
--------------------- >> end captured logging << ---------------------


Last may be trying to access the network.  No idea about the first - don't get it building locally.

Comment 18 Upstream Release Monitoring 2016-12-31 08:06:22 UTC
toshio's python-sphinx-1.5.1-1.fc26 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=830245

Comment 19 Toshio Ernie Kuratomi 2016-12-31 08:15:22 UTC
I've managed to get this built for rawhide.  I'm not very active in Fedora anymore so I'll let someone else decide whether to push the update to f25 and below.

The deco() problem is likely a bug in upstream's test suite.  I didn't fix the testsuite.  Instead I made it so the bug will never trigger by making sure that all the latex packages that the testsuite was checking for are installed.  Doing that makes sure the problematic code never triggers.

I agreed with orion that the latter errors are due to the test suite trying to access the network (the linkcheck extension verifies whether the external links in the documentation are valid or not.  Currently they need to be able to access the network.  The test suite could be reworked to start up a minimal webserver on localhost and test urls that point to those but that was more work than I had time to do.)  Since koji can't access the network, I've disabled those tests in the package build.

I'm not closing this bug as (like I said earlier) I'm not super active in Fedora right now and someone else should make a decision whether to push the package to earlier Fedora or not.

Comment 20 Upstream Release Monitoring 2017-01-19 06:21:39 UTC
toshio's python-sphinx-1.5.1-2.fc26 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=834819

Comment 21 Upstream Release Monitoring 2017-01-19 07:30:55 UTC
toshio's python-sphinx-1.5.1-3.fc26 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=834825

Comment 22 Upstream Release Monitoring 2017-01-27 02:24:14 UTC
toshio's python-sphinx-1.5.1-4.fc26 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=836509

Comment 23 Upstream Release Monitoring 2017-01-31 20:16:52 UTC
toshio's python-sphinx-1.5.1-5.fc26 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=837474

Comment 24 Upstream Release Monitoring 2017-02-11 20:31:00 UTC
releng's python-sphinx-1.5.1-6.fc26 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=855258

Comment 25 Elliott Sales de Andrade 2017-02-17 08:48:22 UTC
docutils 0.13.1 got pushed to Fedora 25 last week or so, so Sphinx is breaking there too, e.g., https://copr-be.cloud.fedoraproject.org/results/qulogic/jupyter/fedora-25-x86_64/00513045-python-nbsphinx/build.log.gz

I think this update needs to go into F25 as well (or a similar patch.)

Comment 26 Toshio Ernie Kuratomi 2017-02-17 15:45:35 UTC
Upstream bug report that points out that this is an incompatibility with docutils 0.13.1: https://github.com/sphinx-doc/sphinx/issues/3212

Comment 27 Fedora Update System 2017-02-17 19:56:33 UTC
python-sphinx-1.5.2-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-afc3506d3d

Comment 28 Toshio Ernie Kuratomi 2017-02-17 20:13:35 UTC
I've unpushed the update as alternatives seems l=to be messing up badly:

python3-sphinx.noarch: E: non-readable /usr/share/man/man1/sphinx-quickstart.1.gz 0
python3-sphinx.noarch: E: non-readable /usr/share/man/man1/sphinx-all.1.gz 0
python3-sphinx.noarch: W: non-executable-in-bin /usr/bin/sphinx-apidoc 644
python3-sphinx.noarch: E: non-readable /usr/share/man/man1/sphinx-apidoc.1.gz 0
python3-sphinx.noarch: W: non-executable-in-bin /usr/bin/sphinx-quickstart 644
python3-sphinx.noarch: E: non-readable /usr/share/man/man1/sphinx-build.1.gz 0
python3-sphinx.noarch: W: non-executable-in-bin /usr/bin/sphinx-build 644
python3-sphinx.noarch: W: non-executable-in-bin /usr/bin/sphinx-autogen 644

Comment 29 Fedora Update System 2017-02-18 18:41:28 UTC
python-sphinx-1.5.2-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8a1ef27a84

Comment 30 Toshio Ernie Kuratomi 2017-02-18 18:51:36 UTC
New update pushed with the rpmlint/alternatives problems fixed.

Comment 31 Fedora Update System 2017-02-20 00:49:40 UTC
python-sphinx-1.5.2-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8a1ef27a84

Comment 32 Fedora Update System 2017-02-27 22:52:54 UTC
python-sphinx-1.5.2-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.