Bug 1378148 - OSP9/10 controller-and-block-storage-upgrade fails: Unknown Property batch_create
Summary: OSP9/10 controller-and-block-storage-upgrade fails: Unknown Property batch_cr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: 10.0 (Newton)
Assignee: mathieu bultel
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks: 1337794
TreeView+ depends on / blocked
 
Reported: 2016-09-21 15:18 UTC by Sofer Athlan-Guyot
Modified: 2016-12-29 16:54 UTC (History)
3 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.20161003064637.d636e3a.1.2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:03:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 370127 None None None 2016-09-21 15:20:41 UTC
Launchpad 1623506 None None None 2016-09-21 15:18:07 UTC

Description Sofer Athlan-Guyot 2016-09-21 15:18:08 UTC
Description of problem: During major upgrade when using "environments/major-upgrade-pacemaker.yaml" we got an immediate error:

ERROR: Failed to validate: : resources.UpdateWorkflow: : Property error: resources.CephMonUpgradeDeployment.properties: Unknown Property batch_create

How reproducible: always

Comment 2 Sofer Athlan-Guyot 2016-09-21 15:20:42 UTC
Added upstream patch.

Comment 4 Omri Hochman 2016-11-07 21:46:20 UTC
unable to reproduce : openstack-tripleo-heat-templates-5.0.0-1.2.el7ost.noarch

Comment 6 errata-xmlrpc 2016-12-14 16:03:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.