Bug 1378156 - TypeError: Must be number, not str
Summary: TypeError: Must be number, not str
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Blivet Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker abrt_hash:7181e7a816d...
Depends On:
Blocks: F25FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2016-09-21 16:08 UTC by Adam Williamson
Modified: 2016-11-15 13:32 UTC (History)
8 users (show)

Fixed In Version: python-blivet-2.1.6-3.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-15 13:32:47 UTC


Attachments (Terms of Use)
File: anaconda-tb (323.88 KB, text/plain)
2016-09-21 16:08 UTC, Adam Williamson
no flags Details
File: anaconda.log (25.46 KB, text/plain)
2016-09-21 16:09 UTC, Adam Williamson
no flags Details
File: dnf.librepo.log (11.60 KB, text/plain)
2016-09-21 16:09 UTC, Adam Williamson
no flags Details
File: environ (482 bytes, text/plain)
2016-09-21 16:09 UTC, Adam Williamson
no flags Details
File: hawkey.log (1.03 KB, text/plain)
2016-09-21 16:09 UTC, Adam Williamson
no flags Details
File: lsblk_output (1.31 KB, text/plain)
2016-09-21 16:09 UTC, Adam Williamson
no flags Details
File: nmcli_dev_list (1.24 KB, text/plain)
2016-09-21 16:09 UTC, Adam Williamson
no flags Details
File: os_info (451 bytes, text/plain)
2016-09-21 16:09 UTC, Adam Williamson
no flags Details
File: program.log (18.70 KB, text/plain)
2016-09-21 16:09 UTC, Adam Williamson
no flags Details
File: storage.log (39.40 KB, text/plain)
2016-09-21 16:09 UTC, Adam Williamson
no flags Details
File: syslog (80.93 KB, text/plain)
2016-09-21 16:09 UTC, Adam Williamson
no flags Details
File: ifcfg.log (4.42 KB, text/plain)
2016-09-21 16:09 UTC, Adam Williamson
no flags Details
File: packaging.log (4.41 KB, text/plain)
2016-09-21 16:09 UTC, Adam Williamson
no flags Details

Description Adam Williamson 2016-09-21 16:08:54 UTC
Description of problem:
Crash happens during iSCSI install with Fedora-Rawhide-20160921.n.0. See https://openqa.fedoraproject.org/tests/35244

Version-Release number of selected component:
anaconda-26.3-1

The following was filed automatically by anaconda:
anaconda 26.3-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.5/site-packages/gi/overrides/GLib.py", line 126, in _create
    v = constructor(args[0])
  File "/usr/lib64/python3.5/site-packages/gi/overrides/GLib.py", line 167, in _create_tuple
    (v, format, _) = self._create(format, args[0][i:])
  File "/usr/lib64/python3.5/site-packages/gi/overrides/GLib.py", line 132, in _create
    return self._create_tuple(format, args)
  File "/usr/lib64/python3.5/site-packages/gi/overrides/GLib.py", line 243, in __new__
    (v, rest_format, _) = creator._create(format_string, [value])
  File "/usr/lib/python3.5/site-packages/blivet/iscsi.py", line 372, in discover
    args = GLib.Variant("(sqa{sv})", (ipaddr, port, auth_info))
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/advstorage/iscsi.py", line 221, in _discover
    r_password=credentials.rPassword)
  File "/usr/lib64/python3.5/threading.py", line 862, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/threads.py", line 251, in run
    threading.Thread.run(self, *args, **kwargs)
TypeError: Must be number, not str

Additional info:
addons:         com_redhat_kdump, com_redhat_docker
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-dvd-x86_64-rawh quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.8.0-0.rc7.git1.1.fc26.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        rawhide

Comment 1 Adam Williamson 2016-09-21 16:08:59 UTC
Created attachment 1203379 [details]
File: anaconda-tb

Comment 2 Adam Williamson 2016-09-21 16:09:00 UTC
Created attachment 1203380 [details]
File: anaconda.log

Comment 3 Adam Williamson 2016-09-21 16:09:02 UTC
Created attachment 1203381 [details]
File: dnf.librepo.log

Comment 4 Adam Williamson 2016-09-21 16:09:03 UTC
Created attachment 1203382 [details]
File: environ

Comment 5 Adam Williamson 2016-09-21 16:09:04 UTC
Created attachment 1203383 [details]
File: hawkey.log

Comment 6 Adam Williamson 2016-09-21 16:09:05 UTC
Created attachment 1203384 [details]
File: lsblk_output

Comment 7 Adam Williamson 2016-09-21 16:09:06 UTC
Created attachment 1203385 [details]
File: nmcli_dev_list

Comment 8 Adam Williamson 2016-09-21 16:09:08 UTC
Created attachment 1203386 [details]
File: os_info

Comment 9 Adam Williamson 2016-09-21 16:09:09 UTC
Created attachment 1203387 [details]
File: program.log

Comment 10 Adam Williamson 2016-09-21 16:09:10 UTC
Created attachment 1203388 [details]
File: storage.log

Comment 11 Adam Williamson 2016-09-21 16:09:11 UTC
Created attachment 1203389 [details]
File: syslog

Comment 12 Adam Williamson 2016-09-21 16:09:12 UTC
Created attachment 1203390 [details]
File: ifcfg.log

Comment 13 Adam Williamson 2016-09-21 16:09:14 UTC
Created attachment 1203391 [details]
File: packaging.log

Comment 14 Adam Williamson 2016-09-21 16:18:14 UTC
This is the latest crash we get in *Rawhide* iSCSI testing, I guess others have been fixed now (or this is a new one that comes before them, I'm losing track). Current F25 is hitting https://bugzilla.redhat.com/show_bug.cgi?id=1378159 .

Proposing as an F26 Final blocker, per criterion "The installer must be able to detect (if possible) and install to supported network-attached storage devices."

Comment 15 Adam Williamson 2016-09-28 22:46:41 UTC
As of Fedora-25-20160928.n.0 , Fedora 25 is hitting this too:

https://openqa.fedoraproject.org/tests/37016

So proposing as 25 Final blocker.

Comment 16 Petr Schindler 2016-10-03 17:07:18 UTC
Discussed at 2016-10-03 blocker review meeting: [1]. 

This bug was accepted as Final blocker: This bug violates "The installer must be able to detect (if possible) and install to supported network-attached storage devices."

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-10-03/

Comment 17 Adam Williamson 2016-10-27 00:14:57 UTC
So this is really kind of a follow-on to https://bugzilla.redhat.com/show_bug.cgi?id=1375712 ; that fixed the syntax of a GVariant tuple constructor, but it didn't fix the fact that one of the values we put in the tuple isn't the right type. I've got a fix for that; I'm now working through all the other things that turn out to be broken *after* that. PRs for blivet and anaconda pending.

Comment 18 Adam Williamson 2016-10-27 07:54:14 UTC
All these PRs, together, fix the openQA iSCSI install test for me:

https://github.com/rhinstaller/anaconda/pull/848
https://github.com/rhinstaller/anaconda/pull/849
https://github.com/rhinstaller/anaconda/pull/850
https://github.com/rhinstaller/blivet/pull/518

I haven't tested that authentication works yet, though, as the openQA test doesn't use it. I can try testing that tomorrow, I'll have to look up how to set it up on the server end.

The fix for this particular bug is the first commit in https://github.com/rhinstaller/blivet/pull/518 , "Use correct type for port in GVariant tuple"; the other patches fix subsequent issues that appear after this bug is fixed.

Comment 19 Adam Williamson 2016-10-27 23:16:30 UTC
One more patch is needed to ensure anaconda populates `/var/lib/iscsi` on the installed system, as intended:

https://github.com/rhinstaller/blivet/pull/520

https://www.happyassassin.net/updates/1378156.12.img is an updates.img with all the patches applied. I've tested both non-authed and authed iSCSI installs with that updates image, and they work fine.

Comment 20 Fedora Update System 2016-11-07 19:29:19 UTC
python-blivet-2.1.6-3.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-91844f4982

Comment 21 Adam Williamson 2016-11-07 19:37:58 UTC
For the record, the blivet fixes alone should suffice to fix non-authenticated iSCSI installs. Authenticated installs also require anaconda-25.20.7-1.fc25 .

Comment 22 Adam Williamson 2016-11-09 00:06:02 UTC
Verified the fix for this with a test installer image. Will re-confirm that all iSCSI issues are fixed with the RC.

Comment 23 Fedora Update System 2016-11-09 02:26:09 UTC
anaconda-25.20.8-1.fc25, python-blivet-2.1.6-3.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-91844f4982

Comment 24 Adam Williamson 2016-11-09 09:06:41 UTC
back to verified. damnit, bodhi, stop this.

Comment 25 Fedora Update System 2016-11-15 13:32:47 UTC
anaconda-25.20.8-1.fc25, python-blivet-2.1.6-3.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.