Bug 137828 - kernel unaligned access
kernel unaligned access
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ernie Petrides
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-01 16:00 EST by satish
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-03 16:05:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description satish 2004-11-01 16:00:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
I am using 2.4.21-20.El.ia64 on red hat enterprise linux AS release 3.

We have a kernel module which keeps puking the below messages to 
the /var/log/messages, and i seem to have no way to stop that. 
Fixing  our driver to avoid this is a solution that we are working 
on. But we still want to stop these messages from coming so that 
someone can use the driver in the meanwhile.  There seem to be no 
compiler option to find the places we are doing this in kernel.

Oct 31 22:09:55 tower kernel: kernel unaligned access to 
0xe00000001d4f4254,
ip=0xa000000000f7e4e0
Oct 31 22:09:55 tower kernel: kernel unaligned access to 
0xe00000001d4f425c,
ip=0xa000000000f7e500
Oct 31 22:09:55 tower kernel: kernel unaligned access to 
0xe00000001d4f42ec,
ip=0xa000000000f0d2d0
Oct 31 22:09:55 tower kernel: kernel unaligned access to 
0xe00000001d4f43a4,
ip=0xa000000000f0eb30

Trying to use prctl or dmesg did not help prevent these messages from 
being dumped. I am looking at some way to stop these messages from 
coming on the /var/log/messages.

prctl --unaligned=silent ls /fs

Any help is muchly appreciated.
Thanks

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
Run some application on the filesystem driver
2.
3.
    

Actual Results:  spew in /var/log/messages

Additional info:

Some method to stop this spew, a brute force will also be good, 
except patching the kernel
Comment 1 satish 2004-11-02 17:16:07 EST
Is there way in which to prevent the message from appearing on console
?. I looked at the kernel sources and it looks like user level
programs  can use the sysctl to prevent thise. In the kernel there's
no way to prevent these warnings from coming. Is there any particular
reason why it's forced on users this way ?
Comment 2 Ernie Petrides 2004-11-03 16:05:24 EST
There is no current way to suppress messages caused by unaligned
accesses from kernel mode.  The reason that this has been "forced
on users this way" is because these scenarios represent kernel bugs,
which should be fixed.

We might in the future provide a mechanism to suppress these messages
(although this would not be the default case).  But for now, you'll
need to fix your driver.

Note You need to log in before you can comment on or make changes to this bug.