Bug 1378336 - Existing nodes get rebuilt after uploading new overcloud-full image
Summary: Existing nodes get rebuilt after uploading new overcloud-full image
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 10.0 (Newton)
Assignee: Jiri Stransky
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-22 07:56 UTC by Marius Cornea
Modified: 2016-12-14 16:03 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-common-5.2.1-0.20160930023248.848ec90.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:03:34 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 350778 None None None 2016-09-23 14:07:04 UTC
Launchpad 1609020 None None None 2016-09-23 14:06:29 UTC

Description Marius Cornea 2016-09-22 07:56:14 UTC
Description of problem:
Existing nodes get rebuild on a 2nd overcloud deploy run, after the  overcloud-full image has been updated.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Deploy overcloud:

source ~/stackrc
export THT=/usr/share/openstack-tripleo-heat-templates
openstack overcloud deploy --templates \
-e $THT/environments/network-isolation.yaml \
-e $THT/environments/network-management.yaml \
-e ~/templates/network-environment.yaml \
-e ~/templates/enable-tls.yaml \
-e ~/templates/inject-trust-anchor.yaml \
-e ~/templates/tls-endpoints-public-ip.yaml \
-e ~/templates/password-env.yaml \
--control-scale 1 \
--control-flavor controller-d75f3dec-c770-5f88-9d4c-3fea1bf9c484 \
--compute-scale 1 \
--compute-flavor compute-b634c10a-570f-59ba-bdbf-0c313d745a10 \
--ntp-server clock.redhat.com 


2. Update image:

[stack@undercloud-0 ~]$ openstack overcloud image upload --update-existing

Image "overcloud-full-vmlinuz" is up-to-date, skipping.
Image "overcloud-full-initrd" is up-to-date, skipping.
Image "overcloud-full" was uploaded.
+--------------------------------------+----------------+-------------+------------+--------+
|                  ID                  |      Name      | Disk Format |    Size    | Status |
+--------------------------------------+----------------+-------------+------------+--------+
| bce2b65d-ebbf-4e62-a5fd-b5891539b980 | overcloud-full |    qcow2    | 1208811520 | active |
+--------------------------------------+----------------+-------------+------------+--------+
Image "bm-deploy-kernel" is up-to-date, skipping.
Image "bm-deploy-ramdisk" is up-to-date, skipping.
Image file "/httpboot/agent.kernel" is up-to-date, skipping.
Image file "/httpboot/agent.ramdisk" is up-to-date, skipping.

3. Rerun deploy command:
source ~/stackrc
export THT=/usr/share/openstack-tripleo-heat-templates
openstack overcloud deploy --templates \
-e $THT/environments/network-isolation.yaml \
-e $THT/environments/network-management.yaml \
-e ~/templates/network-environment.yaml \
-e ~/templates/enable-tls.yaml \
-e ~/templates/inject-trust-anchor.yaml \
-e ~/templates/tls-endpoints-public-ip.yaml \
-e ~/templates/password-env.yaml \
--control-scale 1 \
--control-flavor controller-d75f3dec-c770-5f88-9d4c-3fea1bf9c484 \
--compute-scale 1 \
--compute-flavor compute-b634c10a-570f-59ba-bdbf-0c313d745a10 \
--ntp-server clock.redhat.com 


Actual results:
[stack@undercloud-0 ~]$ nova list
+--------------------------------------+-------------------------+---------+------------------+-------------+-----------------------+
| ID                                   | Name                    | Status  | Task State       | Power State | Networks              |
+--------------------------------------+-------------------------+---------+------------------+-------------+-----------------------+
| da06c2f6-b2c9-4213-a571-5034d7cdd97c | overcloud-controller-0  | REBUILD | rebuild_spawning | Running     | ctlplane=192.168.0.21 |
| 9e99df07-93c8-4666-842b-b9f9c722710b | overcloud-novacompute-0 | REBUILD | rebuild_spawning | Running     | ctlplane=192.168.0.13 |
+--------------------------------------+-------------------------+---------+------------------+-------------+-----------------------+


Expected results:
Existing nodes don't get rebuilt.

Comment 2 Marius Cornea 2016-09-22 07:59:07 UTC
Version-Release number of selected component (if applicable):
python-tripleoclient-5.0.0-0.20160907170033.b0d7ce7.el7ost.noarch
openstack-tripleo-heat-templates-5.0.0-0.20160907212643.90c852e.1.el7ost.noarch
openstack-heat-common-7.0.0-0.20160907124808.21e49dc.el7ost.noarch
python-heatclient-1.4.0-0.20160831084943.fb7802e.el7ost.noarch
openstack-heat-templates-0.0.1-0.20160906185549.ac2db55.el7ost.noarch
openstack-heat-api-cfn-7.0.0-0.20160907124808.21e49dc.el7ost.noarch
openstack-heat-engine-7.0.0-0.20160907124808.21e49dc.el7ost.noarch
puppet-heat-9.2.0-0.20160901072004.4d7b5be.el7ost.noarch
openstack-heat-api-7.0.0-0.20160907124808.21e49dc.el7ost.noarch
python-heat-tests-7.0.0-0.20160907124808.21e49dc.el7ost.noarch


How reproducible:
100%

Comment 3 James Slagle 2016-09-22 16:24:19 UTC
jistr, can you have a look at this one?

Comment 4 Jiri Stransky 2016-09-23 08:10:55 UTC
Yup

Comment 5 Jiri Stransky 2016-09-23 14:06:29 UTC
We had this problem in OSP 9 (bug 1354627) and it was fixed by Thomas, but the fix fell under the radar upstream so it's missing in OSP 10. It's now targeted for Newton RC2.

Comment 12 errata-xmlrpc 2016-12-14 16:03:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.