Bug 1378338 - TypeError: object of type 'generator' has no len()
Summary: TypeError: object of type 'generator' has no len()
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 25
Hardware: s390x
OS: Linux
high
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ZedoraTracker F25s390x
TreeView+ depends on / blocked
 
Reported: 2016-09-22 08:03 UTC by Jan Stodola
Modified: 2016-10-16 18:57 UTC (History)
10 users (show)

Fixed In Version: anaconda-25.20.5-1 anaconda-25.20.5-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-16 18:51:00 UTC


Attachments (Terms of Use)

Description Jan Stodola 2016-09-22 08:03:19 UTC
Description of problem:
There is a traceback after selecting DASD disks on s390x and trying to continue with creating of partitions:

anaconda 25.20.1-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 846, in _check_dasd_formats
    if len(dasds) > 0:
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 979, in on_back_clicked
    rc = self._check_dasd_formats()
TypeError: object of type 'generator' has no len()

Compose URL: http://dl.fedoraproject.org/pub/fedora-secondary/development/25/Server/s390x/os/

Version-Release number of selected component (if applicable):
anaconda-25.20.1-1.fc25

How reproducible:
always

Steps to Reproduce:
1. start vnc installation on s390x
2. proceed to the Installation Destination spoke
3. select all disks and try to proceed to the custom partitioning spoke

Actual results:
traceback

Expected results:
custom partitioning screen displayed

Comment 2 Samantha N. Bueno 2016-10-06 19:16:57 UTC
The root cause of this issue should be fixed with blivet-2.1.6-1 (latest compose has 2.1.5-1); specifically, this commit https://github.com/rhinstaller/blivet/commit/417e08b882d25c34a88c51aae4ae190359797fbe which was part of the fix for bug 1379865.

I'll set this to ON_QA for now since that updated package is available in bodhi. Jan, once a new s390x compose is done containing this new blivet, please retest to verify this now works.

Comment 3 Dan Horák 2016-10-07 07:17:00 UTC
(In reply to Samantha N. Bueno from comment #2)
> The root cause of this issue should be fixed with blivet-2.1.6-1 (latest
> compose has 2.1.5-1); specifically, this commit
> https://github.com/rhinstaller/blivet/commit/
> 417e08b882d25c34a88c51aae4ae190359797fbe which was part of the fix for bug
> 1379865.
> 
> I'll set this to ON_QA for now since that updated package is available in
> bodhi. Jan, once a new s390x compose is done containing this new blivet,
> please retest to verify this now works.

Because blivet-2.1.6-1 is part of the last push to stable, the updated build will be present in today's compose.

Comment 4 Dan Horák 2016-10-11 10:04:42 UTC
The issue seems to be still here with the F-25 Beta RC from http://s390.koji.fedoraproject.org/compose/25/Fedora-25-20161007.0/compose/Server/s390x/ (and python-blivet-2.1.6-1.fc25 is included in the repos)


anaconda 25.20.4-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 848, in _check_dasd_formats
    if len(dasds) > 0:
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 981, in on_back_clicked
    rc = self._check_dasd_formats()
TypeError: object of type 'generator' has no len()

Comment 5 Samantha N. Bueno 2016-10-11 16:38:17 UTC
(In reply to Dan Horák from comment #4)
> The issue seems to be still here with the F-25 Beta RC from
> http://s390.koji.fedoraproject.org/compose/25/Fedora-25-20161007.0/compose/
> Server/s390x/ (and python-blivet-2.1.6-1.fc25 is included in the repos)

Ok, whoops. Turns out this was very simple to fix. And in anaconda.

https://github.com/rhinstaller/anaconda/pull/824

Comment 6 Dan Horák 2016-10-12 12:16:27 UTC
I can confirm the proposed patch fixes this issue. I've used updates=http://junkyard.lab.eng.bos.redhat.com/f25/s390x/updates-1378338.img

Comment 7 Sinny Kumari 2016-10-13 07:18:44 UTC
I also tried with:
updates=http://fedora.danny.cz/s390/updates-1378338.img

as mentioned by Dan on Mailing List https://lists.fedoraproject.org/archives/list/s390x@lists.fedoraproject.org/thread/3X2IQAWJ464T7NRAB4N5JJJXWO7PLJKF/

Latest s390x nightly compose (Fedora-25-20161012.n.0) installs fine with vnc.

Comment 8 Samantha N. Bueno 2016-10-13 18:58:31 UTC
Thanks everybody for testing. And thanks to Dan for creating an updates.img (apologies for not making one myself).

This will be in the next version of anaconda, which I'm building right now.

Comment 9 Fedora Update System 2016-10-14 21:54:26 UTC
anaconda-25.20.5-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-622ac5a94d

Comment 10 Fedora Update System 2016-10-16 18:51:00 UTC
anaconda-25.20.5-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.