Bug 1378390 - OSP-9/10 controller upgrade fails on ceph mon upgrade.
Summary: OSP-9/10 controller upgrade fails on ceph mon upgrade.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: 10.0 (Newton)
Assignee: Giulio Fidente
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks: 1337794
TreeView+ depends on / blocked
 
Reported: 2016-09-22 10:27 UTC by Sofer Athlan-Guyot
Modified: 2016-12-29 16:56 UTC (History)
3 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.20161003064637.d636e3a.1.2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:03:39 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 359410 None None None 2016-09-22 10:46:44 UTC
OpenStack gerrit 370830 None None None 2016-09-22 10:36:06 UTC
Launchpad 1618533 None None None 2016-09-22 10:47:52 UTC
Launchpad 1623942 None None None 2016-09-22 10:36:36 UTC

Description Sofer Athlan-Guyot 2016-09-22 10:27:16 UTC
Description of problem:  Running major upgrade with 'environments/major-upgrade-pacemaker.yaml' on a overcloud with ceph, the process fails with:


chown: cannot access ‘/var/run/ceph’: No such file or directory

The software deployment config is overcloud-UpdateWorkflow-hdatwp7grkt6-CephMonUpgradeConfig-a5jjsbb7rg6a and pointing to the script : /usr/share/openstack-tripleo-heat-templates/extraconfig/tasks/major_upgrade_ceph_mon.sh

As a matter of fact /var/run/ceph is not present on the controller.

At the time of the error the ceph has been upgraded:

ceph-base.x86_64      1:10.2.2-41.el7cp @rhelosp-10.0-ceph-2.0-mon
ceph-common.x86_64    1:10.2.2-41.el7cp @rhelosp-10.0-ceph-2.0-mon
ceph-mon.x86_64       1:10.2.2-41.el7cp @rhelosp-10.0-ceph-2.0-mon
ceph-osd.x86_64       1:10.2.2-41.el7cp @rhelosp-10.0-ceph-2.0-osd
ceph-selinux.x86_64   1:10.2.2-41.el7cp @rhelosp-10.0-ceph-2.0-mon
libcephfs1.x86_64     1:10.2.2-41.el7cp @rhelosp-10.0-ceph-2.0-mon
python-cephfs.x86_64  1:10.2.2-41.el7cp @rhelosp-10.0-ceph-2.0-mon

Comment 3 Omri Hochman 2016-11-07 21:40:00 UTC
unable to reproduce openstack-tripleo-heat-templates-5.0.0-1.2.el7ost.noarch

Comment 5 errata-xmlrpc 2016-12-14 16:03:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.