Bug 1378398 - IPv6 deployment fails with: Error: Error from DataBinding 'hiera' while looking up 'tripleo::trusted_cas::ca_map': (<unknown>): found unexpected ':' while scanning a plain scalar at line 114 column 32 on node overcloud-novacompute-0.localdomain
Summary: IPv6 deployment fails with: Error: Error from DataBinding 'hiera' while looki...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 10.0 (Newton)
Assignee: James Slagle
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-22 10:43 UTC by Marius Cornea
Modified: 2016-12-14 16:03 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.20160929150845.4cdc4fc.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:03:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 363204 None None None 2016-09-22 16:25:28 UTC

Description Marius Cornea 2016-09-22 10:43:13 UTC
Description of problem:
IPv6 deployment fails with the following error:

Error: Error from DataBinding 'hiera' while looking up 'tripleo::trusted_cas::ca_map': (<unknown>): found unexpected ':' while scanning a plain scalar at line 114 column 32 on node overcloud-novacompute-0.localdomain
Error: Error from DataBinding 'hiera' while looking up 'tripleo::trusted_cas::ca_map': (<unknown>): found unexpected ':' while scanning a plain scalar at line 114 column 32 on node overcloud-novacompute-0.localdomain


Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-5.0.0-0.20160907212643.90c852e.1.el7ost.noarch
openstack-puppet-modules-9.0.0-0.20160802183056.8c758d6.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy IPv6 enabled overcloud

source ~/stackrc
export THT=/usr/share/openstack-tripleo-heat-templates
openstack overcloud deploy --templates $THT \
-e $THT/environments/network-isolation-v6.yaml \
-e $THT/environments/network-management.yaml \
-e ~/templates/network-environment-v6.yaml \
-e $THT/environments/storage-environment.yaml \
-e ~/templates/disk-layout.yaml \
-e ~/templates/wipe-disk-env.yaml \
--control-scale 3 \
--control-flavor controller-d75f3dec-c770-5f88-9d4c-3fea1bf9c484 \
--compute-scale 1 \
--compute-flavor compute-b634c10a-570f-59ba-bdbf-0c313d745a10 \
--ceph-storage-scale 1 \
--ceph-storage-flavor ceph-cf1f074b-dadb-5eb8-9eb0-55828273fab7 \
--ntp-server clock.redhat.com 


Actual results:
Deployment fails

Expected results:
Deployment succeeds.

Additional info:
On overcloud-novacompute-0.localdomain hiera fails with:

/usr/share/ruby/psych.rb:205:in `parse': (<unknown>): found unexpected ':' while scanning a plain scalar at line 114 column 32 (Psych::SyntaxError)

which is nova::compute::vncproxy_host in /etc/puppet/hieradata/service_configs.yaml

grep nova::compute::vncproxy_host  /etc/puppet/hieradata/service_configs.yaml 
nova::compute::vncproxy_host: [2001:db8:ca2:4::17]

When setting it to nova::compute::vncproxy_host: 2001:db8:ca2:4::17 the syntax error doesn't show up anymore.

Comment 2 Marius Cornea 2016-09-22 11:24:34 UTC
This appears to be fixed by: https://review.openstack.org/#/c/363204/

Comment 7 errata-xmlrpc 2016-12-14 16:03:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.