Bug 13784 - bash: weird PS1 for special accounts
Summary: bash: weird PS1 for special accounts
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-12 12:19 UTC by giulioo
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-27 18:35:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description giulioo 2000-07-12 12:19:03 UTC
In rh6.x if you su'ed to a "special" account, like postgres, you got the 
usual PS1 prompt.

In 6.9.x the PS1 is exported in /etc/bashrc (instead of /etc/profile), 
which is sourced in .bashrc, which is sourced in .bash_profile; so that if 
you "su"  to postgres you get "bash-2.04$" as prompt, since there is 
no /var/lib/pgsql/{.bash_profile,.bashrc}.

Don't know if this change in behavior is intentional (ie: to let the user 
know it's using a not-normal-account) but it doesn't look a nice thing to 
see :)

Comment 1 Bernhard Rosenkraenzer 2000-08-02 11:56:11 UTC
This is intentional - we've had to move PS1 to /etc/bashrc to fix other bugs
(the bash-specific stuff in /etc/profile was preventing people from using other
shells as /bin/sh).



Note You need to log in before you can comment on or make changes to this bug.